Installation error: Warning: Cannot load module 'SQLite' bec

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
cass
Registered User
Posts: 4
Joined: Mon Feb 09, 2009 3:37 pm

Installation error: Warning: Cannot load module 'SQLite' bec

Post by cass » Mon Feb 09, 2009 3:45 pm

All I want is to install phpBB (not like I haven't done it a million times before...)
I've tried to install both 3.0.3 & 3.0.4 and both come back with the exact same error on installation. I have changed all the file permissions required etc etc etc... and no matter what I do I keep coming up with this same code:

Code: Select all

Warning: Cannot load module 'SQLite' because required module 'pdo' is not loaded in Unknown on line 0
[phpBB Debug] PHP Notice: in file /install/index.php on line 440: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 441: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 442: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 443: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
I have no idea what the heck the problem is... I go to /install/index.php, click the install tab, click 'Proceed to the next step' and this comes up. I haven't even done anything!
Personally I don't even use SQLite, so I have no idea why I would be getting this, or how to fix it!
ARG >< HELP!!!!

cass
Registered User
Posts: 4
Joined: Mon Feb 09, 2009 3:37 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by cass » Mon Feb 09, 2009 9:35 pm

...... anyone?

User avatar
ric323
Registered User
Posts: 102
Joined: Sat Sep 29, 2007 1:09 pm
Location: Melbourne, Australia

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by ric323 » Mon Feb 09, 2009 9:50 pm

Where are you trying to install this? i.e. on what web host?
There seems to be something unusual about their PHP installation, which is confusing the installer when it checks what databases are available.

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by A_Jelly_Doughnut » Mon Feb 09, 2009 10:57 pm

I'm interested in your PHP version as well :)
A_Jelly_Doughnut

cass
Registered User
Posts: 4
Joined: Mon Feb 09, 2009 3:37 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by cass » Tue Feb 10, 2009 12:32 am

Hello - I'm using BlueHost as my hosting company and PHP5
:(

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by A_Jelly_Doughnut » Tue Feb 10, 2009 12:46 am

The exact php version (5.x.y) would be more helpful :)
A_Jelly_Doughnut

User avatar
ric323
Registered User
Posts: 102
Joined: Sat Sep 29, 2007 1:09 pm
Location: Melbourne, Australia

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by ric323 » Tue Feb 10, 2009 12:49 am

This appears to be a common problem on Bluehost. There were a number of people reporting the same error on phpbb.com

I found a solution on Google's cache at http://209.85.175.132/search?q=cache:Y_ ... cd=3&gl=au

Open

Code: Select all

includes/functions_install.php
Find

Code: Select all

    function can_load_dll($dll)
    {
       return ((@ini_get('enable_dl') || strtolower(@ini_get('enable_dl')) == 'on') && (!@ini_get('safe_mode') || strtolower(@ini_get('safe_mode')) == 'off') && @dl($dll . '.' . PHP_SHLIB_SUFFIX)) ? true : false;
    }
Replace with

Code: Select all

    function can_load_dll($dll)
    {
       return false;
       return ((@ini_get('enable_dl') || strtolower(@ini_get('enable_dl')) == 'on') && (!@ini_get('safe_mode') || strtolower(@ini_get('safe_mode')) == 'off') && @dl($dll . '.' . PHP_SHLIB_SUFFIX)) ? true : false;
    }
Note, this is fooling the phpBB installer into thinking it can load all database types, when it can't. This only affects the installer, not normal running of phpBB.
Do NOT pick SQLITE when asked during installation, even though it will be reported as available!

cass
Registered User
Posts: 4
Joined: Mon Feb 09, 2009 3:37 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by cass » Tue Feb 10, 2009 2:39 pm

Worked like a charm! Thank you so much :)

FYI.... PHP version: 5.2.8 (sorry)

KeithR
Registered User
Posts: 23
Joined: Mon Feb 02, 2009 7:22 pm

Re: Installation error: Warning: Cannot load module 'SQLite' bec

Post by KeithR » Tue Feb 10, 2009 8:40 pm

Thankyou for this ric323 I had tried searched through the cached posts on phpBB.com but to no avail, thanks to you I have managed to set up a sub domain for testing. :D

Locked