Time & Date issues after upgrading to 3.0.4

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »


User avatar
pmbinky
Registered User
Posts: 28
Joined: Fri Feb 06, 2009 1:54 am
Location: Suburb of Detroit
Contact:

Re: Time & Date issues after upgrading to 3.0.4

Post by pmbinky »

I'm just grasping at straws now but what happens if you select "Custom" and enter
D M d, Y g:i a
blessings,
Tony <><

Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »

stayed the same.
but each "less than a minute ago" has different setting in the D M d, Y g:i a format.

Plus when I click "Members" and select "Joined" it does have them still listed by the date/time they joined. Also tried merging posts,does put the newest one on top...even though they were both posted "1 hour ago".

User avatar
pmbinky
Registered User
Posts: 28
Joined: Fri Feb 06, 2009 1:54 am
Location: Suburb of Detroit
Contact:

Re: Time & Date issues after upgrading to 3.0.4

Post by pmbinky »

Coolzero wrote:stayed the same.
but each "less than a minute ago" has different setting in the D M d, Y g:i a format.

Plus when I click "Members" and select "Joined" it does have them still listed by the date/time they joined. Also tried merging posts,does put the newest one on top...even though they were both posted "1 hour ago".
If each "less than a minute ago" has a different format then it sounds like the array that defines the choices got hosed somehow. If you put in the D M d, Y g:i a then Submit, re-click the "General" tab and select "Run now" to purge the cache ...

Any luck?
blessings,
Tony <><

User avatar
3Di
Registered User
Posts: 905
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Contact:

Re: Time & Date issues after upgrading to 3.0.4

Post by 3Di »

in UCP every user can select the time style, select the last in the drop-down menu.

in ACP/board settings/ date format also select the last in the drop-down menu.

logout and see, you'll see your board showing the new date format (if not clear your cache folder)

if you (teh user) have selected that one into you UCP then when you login again you'll see the results.
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades

Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »

No to both of those.

Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »

3.0.4 updated my sql...so do I need to restore the DB to an older date?
If so which table would I restore...I could do the whole thing, but I'd lose posts that were done inbetween.

Or if that's not it, then can I jsut delete the new files 3.0.4 put in and bring back the old (.bak) files in their place. Or would that mess it up as it wouldn't be 3.0.4 or 3.0.3?

Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »

Fixed it myself.

I started deleteing the updated files and replace with the ones before updating to 3.0.4.
One of the files in the includes folder is where it was at. I delted and uploaded each folder at at time, then refreshed the page till I noticed the time and date were back to normal. Not sure which file it was as I did the whole folder at once.

User avatar
pmbinky
Registered User
Posts: 28
Joined: Fri Feb 06, 2009 1:54 am
Location: Suburb of Detroit
Contact:

Re: Time & Date issues after upgrading to 3.0.4

Post by pmbinky »

I'm glad you were able to take care of it and I'm sorry I could not have been more help. I had been sitting at this computer all day and needed to get to sleep for church this morning.

Again, congratulations!
blessings,
Tony <><

Coolzero
Registered User
Posts: 14
Joined: Sat Feb 07, 2009 8:28 pm
Location: Indiana

Re: Time & Date issues after upgrading to 3.0.4

Post by Coolzero »

Thanks for your input though.

Bit worried if I should even try upgrading to 3.0.4 again...course in the ACP>System, it thinks I already have 3.0.4
which not all files are now. WIll that hurt anything?

Also, when trying to get it to stop saying "1 hour ago", I did reset the board start date....can I change that back to the orginal date somehow?

Locked