Custom field inquiry

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
DaHiA
Registered User
Posts: 22
Joined: Wed Oct 19, 2005 3:51 am

Re: Custom field inquiry

Post by DaHiA »

I'm 100% positive that i ran the db update successfully
regarding files updating, im not using all new files because i manage to merge some with old.

Would you suggest me to re-run the update from the previous version?
User avatar
Eelke
Registered User
Posts: 606
Joined: Thu Dec 20, 2001 8:00 am
Location: Bussum, NL
Contact:

Re: Custom field inquiry

Post by Eelke »

Sorry, I have no further suggestions. If it were me, I'd probably add some debugging statements in the code to find out what is going on, but that's not something I can talk you through. Hopefully, a regular support team member has some better suggestions for you. (I'm just trying to answer a few support questions to maybe try and relief the phpBB teams to work on the .com outage).
User avatar
Brf
Support Team
Support Team
Posts: 332
Joined: Sun Mar 11, 2007 1:06 pm

Re: Custom field inquiry

Post by Brf »

Likely you have a problem with includes/functions_profile_fields.php. Try using the new one from the 3.0.4 install.
DaHiA
Registered User
Posts: 22
Joined: Wed Oct 19, 2005 3:51 am

Re: Custom field inquiry

Post by DaHiA »

Brf wrote:Likely you have a problem with includes/functions_profile_fields.php. Try using the new one from the 3.0.4 install.
I used a fresh file and overwrite the current but issue persists. :roll:
User avatar
Eelke
Registered User
Posts: 606
Joined: Thu Dec 20, 2001 8:00 am
Location: Bussum, NL
Contact:

Re: Custom field inquiry

Post by Eelke »

I think you'll be happy (well...) to learn that I could reproduce your problem. I replicated your settings and I don't see the field on the registration page either. I think this is a bug (either in the actual logic, or in the language of the configuration screen, because the "Display" option set to no suggests that the field is just not displayed in public areas, but it can be set by e.g. the user themselves). When .com is back, we need to check the bug tracker if this has been reported before and if not, create a bug report.

Edit: Here's the culprit.
Line 41 and on of functions_profile_fields.php

Code: Select all

        case 'register':
            // If the field is required we show it on the registration page and do not show hidden fields
            $sql_where .= ' AND f.field_show_on_reg = 1 AND f.field_no_view = 0';
        break;
 
This code says to not show the field on the registration page if it is "hidden". However, in the ACP, the setting controlling this hiden field implies it only has to do with the "public" display of the field, i.e. whether it should be displayed to other users. This is reinforced by the fact that the field is actually shown on the profile page of the ACP.
User avatar
Eelke
Registered User
Posts: 606
Joined: Thu Dec 20, 2001 8:00 am
Location: Bussum, NL
Contact:

Re: Custom field inquiry

Post by Eelke »

Locked