phpBB won't recognise PostgreSQL?

Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Forum rules
Temporary forum to obtain support while phpBB.com is offline.
Please use the support forum on phpBB.com
Locked
dmkst56
Registered User
Posts: 4
Joined: Mon Feb 02, 2009 1:17 am

phpBB won't recognise PostgreSQL?

Post by dmkst56 » Mon Feb 02, 2009 1:27 am

Please help me!

Two days ago I installed the latest versions of PostgreSQL, PHP and phpBB. PHP and PostgreSQL both work fine, but the phpBB installer doesn't recognise my PostgreSQL installation! I have no idea why and I've never had this kind of thing before... I'm running on Win2k8 with IIS7.

Any help would be appreciated a lot!

Thanks!

User avatar
ToonArmy
Registered User
Posts: 335
Joined: Fri Mar 26, 2004 7:31 pm
Location: Bristol, UK
Contact:

Re: phpBB won't recognise PostgreSQL?

Post by ToonArmy » Mon Feb 02, 2009 1:35 am

You need to ensure the PHP postgres extension is installed and enabled.
Chris SmithBlogXMOOhlohArea51WikiNo support via PM/IM
Image

dmkst56
Registered User
Posts: 4
Joined: Mon Feb 02, 2009 1:17 am

Re: phpBB won't recognise PostgreSQL?

Post by dmkst56 » Mon Feb 02, 2009 1:52 am

Thanks for the quick reply. Would you be so kind as to tell me how to do that, because I'm not sure. I have a php file that consists of a call to phpinfo() and when loading it, I can see that the config has the --with-postgresql option or whatever it is. But if I scroll down the list, I see no mention of PostgreSQL. The php_postgres.dll file (or whatever it is) is in the ext directory as well as in the same directory as php-cgi.exe.

Do you think it would matter that there is a space in the install directory of PHP? I've never seen it like that before, but the installer had it in C:\Program Files\PHP by default and all I did is add a 5.

Edit:
I've already made the extension=php_postgres.dll line is in the php.ini config file.

User avatar
ToonArmy
Registered User
Posts: 335
Joined: Fri Mar 26, 2004 7:31 pm
Location: Bristol, UK
Contact:

Re: phpBB won't recognise PostgreSQL?

Post by ToonArmy » Mon Feb 02, 2009 1:54 am

Edit the php.ini file and to enable the extension.

Should need a line such as

Code: Select all

externsion=php_postgress.dll
it might already exist but be commented out. More info: http://uk.php.net/manual/en/pgsql.setup.php
Chris SmithBlogXMOOhlohArea51WikiNo support via PM/IM
Image

dmkst56
Registered User
Posts: 4
Joined: Mon Feb 02, 2009 1:17 am

Re: phpBB won't recognise PostgreSQL?

Post by dmkst56 » Mon Feb 02, 2009 2:57 am

Thanks,

It's not commented out. I've already been to the php.net page for installing Postgres but found it utterly useless...

User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: phpBB won't recognise PostgreSQL?

Post by A_Jelly_Doughnut » Mon Feb 02, 2009 3:37 am

Have you created a phpinfo() page to ensure that the extension was enabled?
A_Jelly_Doughnut

dmkst56
Registered User
Posts: 4
Joined: Mon Feb 02, 2009 1:17 am

Re: phpBB won't recognise PostgreSQL?

Post by dmkst56 » Mon Feb 02, 2009 4:54 am

I have a phpinfo() page, yes, but how do I use it to check that Postgres is enabled? I have already looked through it and I see no mention of PostgreSQL.

Locked