blob/text error

Discussion on a SQL Parser for EasyMOD
Locked
KanadiaN
Registered User
Posts: 6
Joined: Fri Aug 29, 2003 3:39 am

blob/text error

Post by KanadiaN » Fri Dec 08, 2006 11:50 pm

is there a fix for this? every time i try to install it I get the blob/text error. I needed i will provide the error..

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: blob/text error

Post by Nightrider » Sat Dec 09, 2006 6:01 am

Are you attempting to install EM or a MOD using EM? Go ahead and post the error message...

Image

KanadiaN
Registered User
Posts: 6
Joined: Fri Aug 29, 2003 3:39 am

Re: blob/text error

Post by KanadiaN » Sun Dec 10, 2006 3:57 pm

this is the first error

Code: Select all

Progress :: . Done
Result   :: Some queries failed, the statements and errors are listing below

    * Error :: BLOB/TEXT column 'mod_description' can't have a default value
      SQL   :: CREATE TABLE phpbb_easymod ( mod_id mediumint(8) NOT NULL auto_increment, mod_title varchar(255) NULL DEFAULT '', mod_file varchar(255) NULL DEFAULT '', mod_version varchar(15) NULL DEFAULT '', mod_author_handle varchar(25) NULL DEFAULT '', mod_author_email varchar(100) NULL DEFAULT '', mod_author_name varchar(100) NULL DEFAULT '', mod_author_url varchar(100) NULL DEFAULT '', mod_description text NULL DEFAULT '', mod_process_date int(11) NULL DEFAULT '0', mod_phpBB_version varchar(15) NULL DEFAULT '', mod_processed_themes varchar(200) NULL DEFAULT '', mod_processed_langs varchar(200) NULL DEFAULT '', mod_files_edited mediumint(8) NULL DEFAULT '0', mod_tables_added mediumint(8) NULL DEFAULT '0', mod_tables_altered mediumint(8) NULL DEFAULT '0', mod_rows_inserted mediumint(8) NULL DEFAULT '0', PRIMARY KEY (mod_id))

This is probably nothing to worry about, install will continue. Should this fail to complete you may need to seek help at our development board.
and of course this is the one that would follow because EasyMOD installer could not find the required table

Code: Select all

Progress :: . Done
Result   :: Some queries failed, the statements and errors are listing below

    * Error :: Table 'guild.phpbb_easymod' doesn't exist
      SQL   :: INSERT INTO phpbb_easymod ( mod_title, mod_file, mod_version, mod_author_handle, mod_author_email, mod_author_name, mod_author_url, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited, mod_tables_added, mod_tables_altered, mod_rows_inserted) VALUES ( 'EasyMOD', 'easymod/easymod_install.php', '0.3.0', 'Nuttzy', 'pktoolkit@blizzhackers.com', 'n/a', 'http://www.blizzhackers.com', 'EasyMOD automatically perfoms in seconds which previously required the tedious task of manually editing files.', 1165765773, '2.0.21', 'subSilver; wow_alliance', 'english', 0, 1, 0, 1)
and this is the server setup

Code: Select all

# Server version: 5.0.27-community-nt
# MySQL client version: 5.0.22
# Used PHP extensions: mysql

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: blob/text error

Post by Nightrider » Sun Dec 10, 2006 6:10 pm

* Error :: BLOB/TEXT column 'mod_description' can't have a default value

This appears to be a problem on 5.0.27 servers. There is an easy fix for this, thanks to Kobus' great detective skills...

Could not successfully update table. Install cannot complete

So to correct this problem, do this:

OPEN
easymod/easymod_install.php

FIND

Code: Select all

mod_description text NULL DEFAULT '',
REPLACE WITH

Code: Select all

mod_description text NULL,
Save, upload to the easymod folder, then try the EM install again...

Image

Locked