compatibility with 2.0.x mods

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Post Reply
elfprince13
Registered User
Posts: 5
Joined: Tue Mar 20, 2007 3:02 am

compatibility with 2.0.x mods

Post by elfprince13 »

how similar is the database system between 2.0.x and 3.x? I have a couple personal mods that Ive put a lot of work into that I dont want to have to rewrite when I install Olympus. how much work generally can be expected to get the old code working?

User avatar
Highway of Life
Registered User
Posts: 1399
Joined: Tue Feb 08, 2005 10:18 pm
Location: I'd love to change the World, but they won't give me the Source Code
Contact:

Re: compatibility with 2.0.x mods

Post by Highway of Life »

A complete rewrite of those MODs will be needed.

MODs built for phpBB2 are not even remotely compatible with phpBB3 (and vise-versa).
The structure and Database schema are much too different for phpBB2 MODs to work with.
Nearly every single MOD I have come across has required at least a near complete rewrite to work with phpBB3.
In most cases, it would take longer to try and “port” the MOD, then it would be to just rewrite it.
Image

elfprince13
Registered User
Posts: 5
Joined: Tue Mar 20, 2007 3:02 am

Re: compatibility with 2.0.x mods

Post by elfprince13 »

bleargh, this oughta be fun......

*elfprince13 has way too much on his hands.

Post Reply