unread flags bug? (since phpbb.com down I'm reporting here)

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
User avatar
Nicholas the Italian
Registered User
Posts: 659
Joined: Mon Nov 20, 2006 11:19 pm
Location: 46°8' N, 12°13' E
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Nicholas the Italian »

Nicholas the Italian wrote: Uh... Sorry, where is the toilet?

The second door on the left.
Thanks.
Your welcome.
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

Rats! didn't work this time.
I've seen it so many times and I've tried to reproduce the error, but it's not coming up right now :?

I'll just keep an eye out for it if I see it happen again and mark down the steps to re-create it.
I haven't seen it for almost a week now.
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

but where is that toilet anyway?
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman, had you already seen Nicholas's last post on the prior page before he posted the new one on this page? I think it only happens if you have already read all of the posts on the prior page and then one more is posted to bring you to a new page...so if Nicholas posted twice before you sae those posts it wouldn't have occurred, right?
Alan
User avatar
ChrisRLG
Registered User
Posts: 160
Joined: Wed Oct 11, 2006 9:47 am
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by ChrisRLG »

Handyman wrote:
ChrisRLG wrote: what 20th message would that be - BTW I view from the last post in a topic backwards - so I will not see any problem.

how do you keep up with a topic backwards?


On most forums i am active at, I follow most conversations - so only wish to see the latest posts in each topic.

By setting the right flags in UCP you can change the sort direction of the posts in a topic - such that the last post will be to view when you click the topic subject title in viewforums mode rather that the first post.

I just find it so much more convenient.

It does make me laugh when someone posts about the posts in a topic that are "Above" his - as for me they are below :)

They have just made an assumption that everyone views topics in the same way. With phpBB3 they do not need to :)
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Well, I just tried it a bit more meticulously on my own test phpbb3 board. Here's what I did, which did NOT result in the error:

- set posts per page to 10

- opened up IE and signed in one test user (U!), opened up FF and signed in another test user (U2)

- had U1 start a new topic and post 9 replies to it (10 posts total in the new topic)

- had U2 go to viewforum for the forum in question and click the yellow flag on that new topic so that U1 had read all 10 posts in that topic

- had U1 post another post in that topic so that the last post was now on page 2 of the topic

- had U2 go to viewforum for the forum in question and click the yellow flag on that new topic

Result...everything worked the way it was supposed to (U2 got brought to the first and only post on page 2 of the topic).

Although I would be surprised if this is the difference, the only thing I can think of at this point is that when I run into the trouble I have (I think) always clicked the yellow flag from search.php?search_id=egosearch (rather than from viewforum). I note that when I click from there, the form of the address is slightly different. When I click from there, teh formof the unread post address is this:

viewtopic.php?f=3&t=26342&hilit=&view=unread#unread

rather than this:

viewtopic.php?f=3&t=26342&view=unread#unread

Any chance the hilit= part could somehow mess things up? (Seems very unlikely but I thought I'd throw it out there.)

Handyman, do you use egosearch a lot the way I do to follow topics you have posted to? Would you only possibly only have run into the problem when using egosearch?
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Nope, I couldn't replicate it that way either. Baffling. Nothing worse than an intermittent problem.
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman wrote: I haven't seen it for almost a week now.

Maybe they are 'gaslighting' us... maybe they fixed it secretly last week and aren't telling us ;)

Anyone else seen this in the last week or so?
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

It just happened to me again, and this time I am NOT on the second to last page. The last page I had read was page 56 and the topic is now on page 58, and I can go back agan and again and again clicking the yellow flag and each time it takes me to page 56. I am reluctant to go to the last age and read what I haven't read before because this is sort of a laboratory experiment and I can reproduce the error on this page again and again, but of course I don't know why this topic was special. Any idea of any experiment I should try?
Alan
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

asinshesq wrote: Handyman, had you already seen Nicholas's last post on the prior page before he posted the new one on this page? I think it only happens if you have already read all of the posts on the prior page and then one more is posted to bring you to a new page...so if Nicholas posted twice before you sae those posts it wouldn't have occurred, right?

Yeah, I read it… then pm'd him to give it one more post.
Then I came back a couple hours later and it didn't work. ( or should I say, it worked, but the bug didn't show itself)
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
Post Reply