unread flags bug? (since phpbb.com down I'm reporting here)

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

I know I'm not supposed to report bugs here, but with phpbb down I'm not sure where else to report (and if I trust my memory to remember to do this later when phpbb.com is back on line it will never happen ;) ).

Anyway, when I go to viewforum and click the unread posts flag to the left of a topic and the topic has more than one page, I sometimes get brought to the page before the page that actually has unread posts on it (i.e. I sometimes get brought to a page where I've read all the posts and for that reason none of them have yellow flags). I haven't been able to figure out a pattern for when that happens. Have other people run into this?
Alan
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

the pattern that I see is when I've read every post on a page, when the next post extends the topic an extra page, I get brought to the last page instead of the current page the topic is on.
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman wrote: the pattern that I see is when I've read every post on a page, when the next post extends the topic an extra page, I get brought to the last page instead of the current page the topic is on.


That's the only time I've seen it as well, but I was hesitant to mention that because I don't think it happens every time that situation arises (though maybe I'm wrong about that). Anyway, it sounds like you are confirming that there is in fact a bug relating to this, correct?

By the way, as long as we're talking about unread flags, is there a feature to remark read posts as unread posts form a given point, or is the bookmark feature the only one that deals with that kind of thing?
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Did anyone already pick up this suspected bug in the buglist during the phpbb.com downtime? If not, I'll do it but I didn't want to replicate a bug if it's already been reported.
Alan
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman wrote: the pattern that I see is when I've read every post on a page, when the next post extends the topic an extra page, I get brought to the last page instead of the current page the topic is on.

Handyman, do you know an exact sequence of steps that will reproduce what you and I have seen every time? Acyd Burn just responded in the bug tracker that they cannot reproduce the error, and I have found that I do not see the error every time the first new post is the first post on a subsequent page so there must be more to this than that.
Alan
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

Can you post a link to the bug? it's hard to look through.
I'll post all the steps to recreate it.
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman wrote: Can you post a link to the bug? it's hard to look through.
I'll post all the steps to recreate it.

Ah, does that mean you can reliably reproduce it? Here's the bug link:

http://www.phpbb.com/bugs/phpbb3/ticket ... et_id=5122
Alan
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

it just happened to me again… so I posted the steps to reproduce the error.
Hopefully that was good enough.
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
asinshesq
Registered User
Posts: 156
Joined: Fri May 14, 2004 10:32 pm
Location: NYC

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by asinshesq »

Handyman wrote: it just happened to me again… so I posted the steps to reproduce the error.
Hopefully that was good enough.

Thanks, but that is the same sequence that I have found to work only sometimes. I can't figure out why it happens sometimes and not other times. Are you finding that that sequence runs into the error each and every time? Maybe acyd will figure it out.
Alan
User avatar
Handyman
Registered User
Posts: 522
Joined: Thu Feb 03, 2005 5:09 am
Location: Where no man has gone before!
Contact:

Re: unread flags bug? (since phpbb.com down I'm reporting here)

Post by Handyman »

so far it's happened every time.
BTW, this is post #10, so we'll see what happens.
the 10th post may need to be by someone else for the bug to show… but this will tell.
My phpBB3 Mods || My Mod Queue
Search Engine Friendly (SEO) URLs || Profile link on Avatar and/or Username || AJAX Chat
Display Posts Anywhere || CashMod || AJAX Quick Edit || AJAX Quick Reply

Image
Post Reply