Just another Question 2.0.xx to 3.0.x

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
MKruer
Registered User
Posts: 156
Joined: Sun Jul 20, 2003 9:01 pm

Just another Question 2.0.xx to 3.0.x

Post by MKruer »

Correct me if I am wrong, but as of right now there are only two mods that are currently and officially supported in the phpbb 2.0.xx to 3.0.x (Olympus) upgrade. Those two modes are the Attachment mod and the Sub Forums mod.

If so, I think you can get rid of a lot of the whiners if you were to officially integrate those two mods in to the basic build for phpbb 2.0.xx as a phpbb 2.0.xx advanced.

I only have two mods on my board, the Attachment mod and the Extreme styling, and have been considering adding the Sub Forums mod to help organize the board, but I am a little hesitant to do so without conformation that the Sub Forums mod has a legitimate upgrade path. (I guess the worst that could happen is the each Sub Forum becomes its own root forum, and I would have to reassign the sub forums to the appropriate place again after Olympus comes out.

DeadEye686
Registered User
Posts: 448
Joined: Mon Jul 21, 2003 7:18 pm
Contact:

Re: Just another Question 2.0.xx to 3.0.x

Post by DeadEye686 »

I don't believe the subforums mod is/will be supported by the upgrade script unless something has changed.

Graham
Registered User
Posts: 1304
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK

Re: Just another Question 2.0.xx to 3.0.x

Post by Graham »

As it stands at the minute, the Attachment MOD is supported in the upgrade script. The other one you mention is not.

Oh - and we won't be releasing any pre-MODded versions of 2.0.x as per long discussions here and on the main site ;)
"So Long, and Thanks for All the Fish"

Graham
Eeek, a blog!

MKruer
Registered User
Posts: 156
Joined: Sun Jul 20, 2003 9:01 pm

Re: Just another Question 2.0.xx to 3.0.x

Post by MKruer »

By the other one, are you refering to the subforums?

User avatar
the_dan
Registered User
Posts: 700
Joined: Thu Apr 01, 2004 7:36 pm

Re: Just another Question 2.0.xx to 3.0.x

Post by the_dan »

MKruer wrote: By the other one, are you refering to the subforums?
Yes. It has been stated that the only supported MOD will be the attatchment one.

User avatar
naderman
Consultant
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: Just another Question 2.0.xx to 3.0.x

Post by naderman »

How simple/difficult will it be to change the upgrade script for other MODs? Is there some plugin mechanism in the upgrade for MODs or something similar that makes upgrading with MODs without loss of data possible?

naderman

Wert
Registered User
Posts: 400
Joined: Tue Jul 03, 2001 8:33 pm

Re: Just another Question 2.0.xx to 3.0.x

Post by Wert »

naderman wrote: How simple/difficult will it be to change the upgrade script for other MODs?
It's not planned. Mods will not carry over as far as I know, upgrade script or not. Even the attachment mod is re-written for olympus and is not really a "mod" anymore in that regard. It's an integral part of olympus.

Is there some plugin mechanism in the upgrade for MODs or something similar that makes upgrading with MODs without loss of data possible?
Nope. Aside from the aforementioned attachment mod, I don't see this happening unless individual mod authors offer an upgrade path. I sincerely doubt you'll see anything official on this. So if you have a lot of mods that heavily modify existing phpBB tables, you might have a bit of a nightmare upgrade. One good reason to not go crazy with modding one's forum.
Need good web hosting? I recommend Hostrocket.

User avatar
naderman
Consultant
Posts: 1727
Joined: Sun Jan 11, 2004 2:11 am
Location: Karlsruhe, Germany
Contact:

Re: Just another Question 2.0.xx to 3.0.x

Post by naderman »

Wert wrote: It's not planned. Mods will not carry over as far as I know, upgrade script or not. Even the attachment mod is re-written for olympus and is not really a "mod" anymore in that regard. It's an integral part of olympus.
I think you didn't really get what I meant ;-) I wanted to know how simple it will be for me to edit the official upgrade script to transfer the data of 2.0.x MODs to my new 3.0.x board, it's only about the data not about what MODs and whether their functionality is now covered by 3.0.x itself just about transfering the data so I can still use it when I apply the MOD (of course rewritten to work with 3.0) to my 3.0 board.

Wert wrote: Nope. Aside from the aforementioned attachment mod, I don't see this happening unless individual mod authors offer an upgrade path. I sincerely doubt you'll see anything official on this. So if you have a lot of mods that heavily modify existing phpBB tables, you might have a bit of a nightmare upgrade. One good reason to not go crazy with modding one's forum.
I wanted to know how these "upgrade paths" by MOD authors are going to look like, nothing to do with official upgrade scripts but with an interface for upgrade paths written by MOD authors.

naderman

User avatar
psoTFX
Registered User
Posts: 1984
Joined: Tue Jul 03, 2001 8:50 pm
Contact:

Re: Just another Question 2.0.xx to 3.0.x

Post by psoTFX »

If you search way back you'll find I made a comment about the possibility of introducing further code to enable mods to be upgraded (beyond attachments). It's something as "CTO" I'd still like to see happen. However you'll need to talk to Graham about it. Certainly if we can assist (where possible ...) with introducing functionality to upgrade existing mods to new functionality in 3.x I'd like to see it happen.

Graham
Registered User
Posts: 1304
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK

Re: Just another Question 2.0.xx to 3.0.x

Post by Graham »

It's going to largely depend on the way the MODs work. It will certainly be possible to adapt the upgrade script to specify additional fields or tables to convert (assuming that the MOD author is able to provide a mapping from their fields to the relevant ones in 3.0) and I expect that there will be information available on how to do this.

Whether this will go to the point of a plug-in system for pulling in extra files for upgrading MODs as one person has suggested, I doubt because I'm not sure it will work with the way most MODs are written and the way the upgrade works.

Equally, I'm not going to commit to providing an included upgrade path from more than the one MOD, although it may happen - we do already have support for one other trivial MOD in there after all.
"So Long, and Thanks for All the Fish"

Graham
Eeek, a blog!

Post Reply