Updating to Olympus

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
User avatar
DooBDee
Registered User
Posts: 17
Joined: Mon Feb 07, 2005 5:10 pm
Location: United Kingdom
Contact:

Updating to Olympus

Post by DooBDee »

Hello there.

I just cant wait till this release is avaiable.

Anyway, i am currently running 2.0.13, and as always, will there be an upgrade script available?

Ie :

Overwrite changed files
Run update_to_latest.php (or similar)

I have no mods installed.

Thanks in advance.
q3utom
Registered User
Posts: 172
Joined: Sun Aug 10, 2003 8:53 pm
Location: folkestone, kent, uk
Contact:

Re: Updating to Olympus

Post by q3utom »

Yes there will be when it is released.
ecwpa
Registered User
Posts: 181
Joined: Mon Jan 24, 2005 2:10 am
Contact:

Re: Updating to Olympus

Post by ecwpa »

how it'll be for hard moded forums?
Slightly better English than it was in 2005, still improving :D
APTX
Registered User
Posts: 680
Joined: Thu Apr 24, 2003 12:07 pm

Re: Updating to Olympus

Post by APTX »

If the mods don't alter the default table fields then (depending on how the install script is written) it should work.
Don't give me my freedom out of pity!
User avatar
olger901
Registered User
Posts: 536
Joined: Tue May 11, 2004 4:57 pm

Re: Updating to Olympus

Post by olger901 »

APTX wrote: If the mods don't alter the default table fields then (depending on how the install script is written) it should work.
Not entirely true, for example if a MOD added a table called phpbb_attachments, and the upgrade script tries to add a table called phpbb_attachments, the installation could fail, and return with the error that the table already exists, however I do believe a few MODs (including the attachment MOD) will have upgrade scripts so they should not have this problem, however some other MODs could.
-
APTX
Registered User
Posts: 680
Joined: Thu Apr 24, 2003 12:07 pm

Re: Updating to Olympus

Post by APTX »

The attachements mosd was written by Acid Burn a phpBB team member. The attachement mod is said to be upgradeable with the upgrade script.
But for all other mods this shouldn't work.
Don't give me my freedom out of pity!
jeffrosproto
Registered User
Posts: 10
Joined: Sun Mar 06, 2005 2:11 am

Re: Updating to Olympus

Post by jeffrosproto »

What if you run a snapshot, will you be able to upgrade from that? I am just debating on weather or not to run the snapshot on my server.
Dunvallo
Registered User
Posts: 64
Joined: Fri Nov 19, 2004 5:55 pm

Re: Updating to Olympus

Post by Dunvallo »

No upgrade will be provided from snapshots to beta. The new version is still in heavy development and compilance with earlier snapshots may be broken at any time. So it is not even possible to provide any way of upgrading. You should wait for at least beta to run PhpBB 3.0 in anything other than a testing environment.
Perhaps you could upgrade your snapshots to beta yourself, but you would have to be very skilled in scripting with php and working with sql databases to do this, since you have to fix all the bugs you get yourself. ;)
The snapshots are unsupported, only beta and later will be supported and (if nothing fails) an upgrade path from 2.0.13 to beta and later on to 3.0 will be provided.
jeffrosproto
Registered User
Posts: 10
Joined: Sun Mar 06, 2005 2:11 am

Re: Updating to Olympus

Post by jeffrosproto »

Well, i installed it, and people are really happy with it, so what do you reccomend I do? I just don't want them to go through moving for the 6th time (Really, that's true) :oops:
Natan
Registered User
Posts: 304
Joined: Tue Dec 30, 2003 4:31 pm
Contact:

Re: Updating to Olympus

Post by Natan »

They have said that the snapshots are completely unsupported and shouldn't be run in a live environment. That's what happens ;)
"You may only be one person to the world, but you may also be the world to one person."
Post Reply