php 5

Discussion of general topics related to the new version and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
Forum rules
Discussion of general topics related to the new release and its place in the world. Don't discuss new features, report bugs, ask for support, et cetera. Don't use this to spam for other boards or attack those boards!
delljustin
Registered User
Posts: 3
Joined: Thu Sep 30, 2004 10:18 pm

php 5

Post by delljustin »

Will the new board, PHPBB 2.2 support the new version of PHP. Thanks.
User avatar
kuato
Registered User
Posts: 41
Joined: Fri Feb 13, 2004 11:00 pm
Contact:

Re: php 5

Post by kuato »

Let's hope so :) I can't speak for the developers but the current code does have problems with PHP5, mostly with array_merge. If you have time you can fix them to make it work. A couple things that need to be done:
  • You cannot mix scalars with arrays in the arguments to array_merge. If you do you get a warning and an empty array returned. A temporary fix is to cast scalars to arrays first.
  • If one of the arrays is empty in the arguments to array_merge you'll get an empty array returned. An easy temporary fix is to check if the array is empty and to not pass it in the call.
I am running phpbb 2.1.2 with PHP 5.0.2 but with tweaks to array_merge as mentioned above. With those it runs great :)
Paul Schmidt - aka kuato
My home | My portal for phpbb2.2
User avatar
Viperal2
Registered User
Posts: 223
Joined: Tue Jun 08, 2004 9:28 pm
Contact:

Re: php 5

Post by Viperal2 »

i only had that problem with the search, do almost all my testing on php5. will with php5.01 there was problem with the registering long veriables ( or maybe it was because i used mmcache !) it didn't register some $_SERVER but was fixed in php5.02. ( or maybe it thank i now don't hae mmcahe !)

form what the developers say there wouldn't be any formal support for php5. but i think it will show up.
What is The Viperal ?

http://developer.berlios.de/projects/viperals/" target="_blank
User avatar
A_Jelly_Doughnut
Registered User
Posts: 1780
Joined: Wed Jun 04, 2003 4:23 pm

Re: php 5

Post by A_Jelly_Doughnut »

Viperal2 wrote: form what the developers say there wouldn't be any formal support for php5.
Only for 2.0.x. 2.2 should work on 5 out of the box.
A_Jelly_Doughnut
delljustin
Registered User
Posts: 3
Joined: Thu Sep 30, 2004 10:18 pm

Re: php 5

Post by delljustin »

Viperal2 wrote: Only for 2.0.x. 2.2 should work on 5 out of the box.
I hope so, could a developer please give me an answer (it doesn't have to be immediate).
Talikar
Registered User
Posts: 2
Joined: Fri Oct 01, 2004 5:09 am

Re: php 5

Post by Talikar »

I know I'm not a dev but I've been testing the CVS version of php 2.2 for awhile, nice board.

Anyway, my server is running off of php 5.0.0 and there is no problems at all with the CVS version. I mean everything works. So I would only assume that it would all work on the final version when it comes out. 8)
Graham
Registered User
Posts: 1304
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK

Re: php 5

Post by Graham »

I'll step up and answer this until one of the developers gets here :)

Yes, phpBB 2.2 will support PHP 5.0.x when it is released (whether official support will be added to the 2.0.x line in the future has not been decided).

There are still a few minor issues with it (but most of them affect PHP 4.x as well), but these should be resolved before the final release.
"So Long, and Thanks for All the Fish"

Graham
Eeek, a blog!
delljustin
Registered User
Posts: 3
Joined: Thu Sep 30, 2004 10:18 pm

Re: php 5

Post by delljustin »

Thanks, Graham. I thought this was the case but I wasn't sure. PHPBB is a great product!! Keep up the good work developers.
User avatar
skrypt
Registered User
Posts: 34
Joined: Wed May 05, 2004 4:39 am
Location: Québec, Canada
Contact:

Re: php 5

Post by skrypt »

Yeah same here I'm running the CVS version on my WIndows 2003 box with PHP 5 installed and the only bug I got is in the installation.
I get "unable to fetch array" errors but it does'nt seems to cause the installation to fail.
User avatar
skrypt
Registered User
Posts: 34
Joined: Wed May 05, 2004 4:39 am
Location: Québec, Canada
Contact:

Re: php 5

Post by skrypt »

I want to say that I whas wrong. With PHP5 under Windows 2003 when you go to the Administration Control Panel I whas not able to see the left panel where the options of administrations are. It whas showing only a "row2" grey panel.
Post Reply