can't install easymod

Want to share what MODs you've gotten to work with EM? Happy about all the time your're saving? Want to say "thanks"? Here's the place.
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
gmanuk
Registered User
Posts: 8
Joined: Sun Feb 19, 2006 8:50 pm

can't install easymod

Post by gmanuk » Mon Jul 10, 2006 2:35 pm

Hi,

I was using easymod without any problems and then I decided to start a fresh forum without any mods but keep all my posts and member information.

I went to install easymod today and it tells me that easymod already exists and that if I want to instal it again I need to change the version in admin. It is not available in admin thought as my forum is a fresh copy.

I don't understand how to re-install this now? Any ideas?

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: can't install easymod

Post by Nightrider » Mon Jul 10, 2006 7:38 pm

EM Version Change

If you already had EM 0.3.0 installed, then you will need to change the EM Version back so that the install will think that this is an Upgrade. You can use this tool to change your EM Version so that you can reinstall EM on your board:

EM_Version_Changer

Once the EM Version Changer is installed, set the EM version to 0.1.13 or 0.2.0...

EM Version Change (Manual Option)

If you want to manually change the EM version, you can do so in your phpbb_config table. Just look for the record beginning with EM_version. Then you can change the related field to 0.1.13. You could also delete all the records in the phpbb_config table that begin with EM_ and delete the phpbb_easymod table too to have the new install recreate everything...

phpMyAdmin - Manually Changing the EM Version Number

The following is how you manually modify your EM password using phpMyAdmin. You can get into your database through your CPanel by clicking on phpMyAdmin. Follow the following instructions:

I'm sure that every host is different. I will tell you how I run my queries manually and hopefully it will be close to what you have available to you. The following may or may not be similar to what you have...

Log into your domain Control Panel and find the database icons. You should be able to find the phpMyAdmin icon. Click on it...

Image

Hopefully that will log you into your phpAdmin panel. You may need to provide a username and password...

In the phpMyAdmin panel, click on the Databases hyperlink...

Image

Hopefully that should take you where you can select your database. You may only have one. Select your database hyperlink...

Image

That should open up the display of all the tables in your database. Ignore them. Somewhere on the page, you should see something similar to this:

Image

Click on the phpbb_config table in the Left column navigation bar:

Image

Then on the top left of the right window, click on the Browse button:

Image

Then to display all the records, change the row settings to 500 starting with record 0, then press the Show button:

Image

Scroll down to the EM version field, then click on the little pencil icon next to the record to edit it:

Image

Enter the following into the config_value Value editbox. Any version less than your current version will work...

Code: Select all

0.1.13
Image

Then press the Go button. You should now be able to reinstall EM...

If you are still unclear on how to do this, send me a PM and I can probably reset your EM version for you...

Image

gmanuk
Registered User
Posts: 8
Joined: Sun Feb 19, 2006 8:50 pm

Re: can't install easymod

Post by gmanuk » Mon Jul 10, 2006 8:51 pm

Thanks nightrider,

it seems to have worked but when I go to admin and click to install a mod it is saying my password is invalid for easymod. I installed it again and double checked the password but it still says invalid. Dont know whats going on?

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: can't install easymod

Post by Nightrider » Mon Jul 10, 2006 9:29 pm

EM Password Change

Here are a couple of ways to fix that:
  1. Blank EM Password

    You can go directly into your phpbb_config table and find the record which starts with EM_password. Copy and paste the following in the following field. This will make it so you can enter EM without any password...

    Code: Select all

    d41d8cd98f00b204e9800998ecf8427e
    phpMyAdmin - Manually Changing the EM Password

    The following is how you manually modify your EM password using phpMyAdmin. You can get into your database through your CPanel by clicking on phpMyAdmin. Follow the following instructions:

    I'm sure that every host is different. I will tell you how I run my queries manually and hopefully it will be close to what you have available to you. The following may or may not be similar to what you have...

    Log into your domain Control Panel and find the database icons. You should be able to find the phpMyAdmin icon. Click on it...

    Image

    Hopefully that will log you into your phpAdmin panel. You may need to provide a username and password...

    In the phpMyAdmin panel, click on the Databases hyperlink...

    Image

    Hopefully that should take you where you can select your database. You may only have one. Select your database hyperlink...

    Image

    That should open up the display of all the tables in your database. Ignore them. Somewhere on the page, you should see something similar to this:

    Image

    Click on the phpbb_config table in the Left column navigation bar:

    Image

    Then on the top left of the right window, click on the Browse button:

    Image

    Then to display all the records, change the row settings to 500 starting with record 0, then press the Show button:

    Image

    Scroll down to the EM Password field, then click on the little pencil icon next to the record to edit it:

    Image

    Enter the following into the config_value Value editbox:

    Code: Select all

    d41d8cd98f00b204e9800998ecf8427e
    Image

    Then press the Go button. You should now be able to log into EM without entering a password. Once you get into EM again, you can add another password in EM Settings if you prefer to have one...

    If you are still unclear on how to do this, send me a PM and I can probably reset your EM password for you...
  2. EM Password Utility

    Try uploading this file to your admin folder and running it in your browser...

    Change EM Password (empw.php)

    You have to remove the .txt extension from the empw.php.txt file before you can run it. Remove the .txt extension and upload it into your admin folder. Then run the empw.php file from your browser.

    The path should look something like this in your browser:

    Code: Select all

    http://yourdomain.com/phpBB/admin/empw.php
    You will be asked to provide your new Password twice along with your FTP password. You will probably see a couple of errors, but the utility seems to work fine still. You will want to rename or delete this file when you are finished...
Image

gmanuk
Registered User
Posts: 8
Joined: Sun Feb 19, 2006 8:50 pm

Re: can't install easymod

Post by gmanuk » Mon Jul 10, 2006 10:50 pm

Thanks again Nightrider,

The password utility worked :D

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: can't install easymod

Post by Nightrider » Mon Jul 10, 2006 10:59 pm

Congratulations gmanuk!!! Image

If you have any additional questions, comments, or concerns, don't hesitate to speak up. If I can, I will be more than happy to help you...

Image

gmanuk
Registered User
Posts: 8
Joined: Sun Feb 19, 2006 8:50 pm

Re: can't install easymod

Post by gmanuk » Tue Jul 11, 2006 7:39 am

Hi nighrider,

easymod is working fine but I am trying to install Simple Subforums and I am getting a critical error. I made a post in the Simple Subforums thread but I don't understand what they are telling me.

Would you be able to help me? I am prepared to pay for the time it takes to install it.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: can't install easymod

Post by Nightrider » Tue Jul 11, 2006 7:45 am

Yes, I would be happy to help you. The Simple Subforums MOD is not an easy MOD to install. In another topic, we renamed it the NSS Subforums MOD (Not So Simple)...

If you want me to install it, send me a PM and we can go from there. Otherwise I need to know the Critical Error message along with a text link to the phpBB file in conflict...

Image

leewells
Registered User
Posts: 11
Joined: Sun Feb 25, 2007 2:24 pm
Location: Dudley, NC USA
Contact:

Re: can't install easymod

Post by leewells » Sun Feb 25, 2007 6:32 pm

Likewise, when I try and install Simple Subforums MOD 1.0.2 it doesn't even show. Did the more recient versions of SSM do away with the easymod compatibility? Or are ya secretly using an xml parser that I don't know about? =P

Seriously I cannot even get easymod to recognize that the package is there.
"There are 3 types of people in this world; those whom can count and those whom cannot."
The Divine Reapers | Olympus-Mods & subBlack for Olympus (now DivineBlack)

Locked