Error installing: path doesn't exist

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
kburright
Registered User
Posts: 3
Joined: Sat Nov 24, 2007 10:40 pm

Error installing: path doesn't exist

Post by kburright »

I installed EasyMod today and started installing mods. Two installed fine, Admin Userlist and Admin Userlist Reg IP Add On (though the latter won't work). After that, I can't get anything to install. Several give me errors in a path dedicated to some of my templates (none I'm using) and the ones that go through everything but the final process seem to install until the last step where I get this message:

(From installing Spam Words)

Warning: copy(../posting.php) [function.copy]: failed to open stream: Permission denied in /hermes/web03/b322/pow.lackofoxygen/htdocs/kburright/everythingbutkids/admin/em_includes/em_modio.php on line 544

General Error
Critical Error: modio_move[1]

COPY ERROR: could not move file [mods/spamwords/processed/posting.php.txt] to [../posting.php]
ATTEMPING REMAINDER OF POST PROCESS

The thing is, there is no path at:
/hermes/web03/b322/pow.lackofoxygen/htdocs/kburright/everythingbutkids/admin/em_includes/em_modio.php

The only path close to that would be: /hermes/web03/b322/pow.lackofoxygen/htdocs/kburright/everythingbutkids/admin/mods/easymod/em_includes/em_modio.php

I've tried about seven different mods, mostly for stopping spambots (all from phpBB) and I get this same error that thinks a path exists from /admin/em_includes when it doesn't. I even restored my database and reinstalled EasyMod. Either I just keep managing to pick the wrong mods, or something is going on that I can't figure out. Also, files in /admin/mods/easymod/em_includes all have the proper permissions.
User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Error installing: path doesn't exist

Post by Lumpy Burgertushie »

first, when easymod installs, it creates that folder in your admin folder.

the question then becomes, why did you delete it or not let it install.

second,
the only spam bot MOD you need is the RAC MOD. It has been 100% effective since it was released.
and it can't be installed by easymod because there are some decisions that you have to make.

robert
kburright
Registered User
Posts: 3
Joined: Sat Nov 24, 2007 10:40 pm

Re: Error installing: path doesn't exist

Post by kburright »

I never deleted that folder or didn't let it install. I followed all the instructions exactly. I even reinstalled. There was never an em_includes folder created in /admin.
User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Error installing: path doesn't exist

Post by Lumpy Burgertushie »

well that is a mystery to me. every single install I have done of easymod ( hundreds at least ) creates that folder in the admin folder.

manually move/copy it to the admin folder from the easymod folder on your computer and see what happens.

if it does not copy this folder, then it probably won't copy others and you will probably get other errors.

you may have to just install easymod manually .

robert
kburright
Registered User
Posts: 3
Joined: Sat Nov 24, 2007 10:40 pm

Re: Error installing: path doesn't exist

Post by kburright »

Okay, today I went to add Rec Mod and I figured while I was at it, I'd try to get the Admin Userlist Reg IP mod to work, only manually. While I was browsing about my file listing in FTP, I discovered that admin/em_includes is there now. I reset the permissions on the files and now everything installs normally.

I haven't touched easymod or edited anything since I posted my first message. The em_includes folder was not in /admin and now it is.

I don't know what's going on, but I'm going to assume it's just one of those things and do another db backup.

Thanks for pointing me to Rec Mod. Any advice on a mod to deter spammers that aren't bots or a better IP/hostname ban utility?
User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Error installing: path doesn't exist

Post by Lumpy Burgertushie »

kburright wrote:Okay, today I went to add Rec Mod and I figured while I was at it, I'd try to get the Admin Userlist Reg IP mod to work, only manually. While I was browsing about my file listing in FTP, I discovered that admin/em_includes is there now. I reset the permissions on the files and now everything installs normally.

I haven't touched easymod or edited anything since I posted my first message. The em_includes folder was not in /admin and now it is.

I don't know what's going on, but I'm going to assume it's just one of those things and do another db backup.

Thanks for pointing me to Rec Mod. Any advice on a mod to deter spammers that aren't bots or a better IP/hostname ban utility?
what kind of spammers? are they posting? or are they just showing up in the memberlist?

robert
Locked