Group Rank Hack Install problem!

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Group Rank Hack Install problem!

Post by Nightrider » Thu Jan 18, 2007 9:07 am

Could you give me a text link to your lang_admin.php file???

Image

JusTwistedd
Registered User
Posts: 31
Joined: Wed Jan 17, 2007 9:28 pm
Location: Ontario, Canada
Contact:

Re: Group Rank Hack Install problem!

Post by JusTwistedd » Thu Jan 18, 2007 9:13 am

I believe the EM Group Rank Install doubled all the codes i put in manually LOL

http://virtualdodge.com/lang_admin.txt

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Group Rank Hack Install problem!

Post by Nightrider » Thu Jan 18, 2007 9:22 am

Message no longer applies since you successfully corrected the problem...

Image
Last edited by Nightrider on Thu Jan 18, 2007 9:28 am, edited 1 time in total.

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Group Rank Hack Install problem!

Post by Nightrider » Thu Jan 18, 2007 9:26 am

JusTwistedd wrote: Problem is now...you know how I installed the code manually before? I think this EM install doubled everything?

You were supposed to remove that code that you manually added. EM doesn't know that you added code to the files. It does exactly as it is told to do...

I need to go to bed. So you should go through your code and manually remove the code that you added. Or you can use EM to Restore the Backups, then restore the backups you should have made before you modified anything, then reinstall the MOD using EM. That would be the easiest option if you made backups before manually modifying your files...

Restoring EM Backups

If a MOD that you installed with EM hosed your board or you decide that you just don't want it, simply go into EM History in your ACP MOD Center and click on the Details button next to the MOD entry..

Image

On the bottom of the next page, select Restore Backups and press the Go button. Make sure you DON'T select the Remove Record option or you will be forced to manually rolll back the EM backups that were created for you. I will have to walk you through that if need be...

Image

Next you will see a page to confirm eht operation. You would choose Yes:

Image

MODs can only be uninstalled in reverse order that they were installed: FILO (First In, Last Out). So if you installed a MOD, then several others, then decided to remove the first one, you would have to Restore the backups of the other MODs before you could Restore the backups on the first MOD...

Restoring EM Backups (Manual Instructions)

Download the backups folder that EM created for you in the MOD sub-folder found in admin/mods. Strip the .txt extension from each file in every folder in the backups folder. So the resulting file extensions will be php, tpl, css, and cfg. Upload the files back to their proper locations on your board; i.e.
  • copy backups/admin/*.* to phpBB/admin/*.*
  • copy backups/includes/*.* to phpBB/includes/*.*
  • copy backups/language/lang_english/*.* to phpBB/language/lang_english/*.*
  • copy backups/templates/subSilver/*.* to phpBB/templates/subSilver/*.*
  • copy backups/*.* to phpBB/*.*
Of course if you have alternate templates and language folders, you will need to copy the files for them as well. I'm referring to phpBB as your forum's root folder in the above copy commands. If your root folder has any other name, just substitute phpBB with the name of your forum's root folder name...

Image

JusTwistedd
Registered User
Posts: 31
Joined: Wed Jan 17, 2007 9:28 pm
Location: Ontario, Canada
Contact:

Re: Group Rank Hack Install problem!

Post by JusTwistedd » Thu Jan 18, 2007 9:28 am

I already went threw the few files i manually edited!

Thanks for the great help man! Ill be using EM all the time.

Ill be sure to send you a Paypal Donation!!!!

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Group Rank Hack Install problem!

Post by Nightrider » Thu Jan 18, 2007 6:43 pm

So is everything working correctly now? Did you remember to run the install_gr_hack.php from your browser in order to update your database???

Image

JusTwistedd
Registered User
Posts: 31
Joined: Wed Jan 17, 2007 9:28 pm
Location: Ontario, Canada
Contact:

Re: Group Rank Hack Install problem!

Post by JusTwistedd » Fri Jan 19, 2007 4:34 am

Yup. Everything is running correctly ;) Thank you so much!

User avatar
RyosukeZ
Registered User
Posts: 302
Joined: Sun Oct 01, 2006 12:40 am
Location: Woodlands, Singapore
Contact:

Re: Group Rank Hack Install problem!

Post by RyosukeZ » Thu Feb 01, 2007 8:58 am

Well, Congratulations!

If you need more help just give us a shout ^^
Bored? Come and have fun at my forum!!
Lets rock the hse!!

User avatar
RyosukeZ
Registered User
Posts: 302
Joined: Sun Oct 01, 2006 12:40 am
Location: Woodlands, Singapore
Contact:

Re: Group Rank Hack Install problem!

Post by RyosukeZ » Sun Mar 04, 2007 8:02 am

Ok, now a new problem ..
I'm running a localhost, i'll upload the files to my site soon.

After i installed some mods using easymod, i install multiple ranks with staff view, after that my acp is gone.

http://img228.imageshack.us/img228/3261 ... ankif5.png

Also, me having problems with vBulletin DHTML menu style.
http://www.phpbb.com/phpBB/viewtopic.php?t=388873

http://img228.imageshack.us/img228/6729 ... enuwa2.png
Bored? Come and have fun at my forum!!
Lets rock the hse!!

User avatar
RyosukeZ
Registered User
Posts: 302
Joined: Sun Oct 01, 2006 12:40 am
Location: Woodlands, Singapore
Contact:

Re: Group Rank Hack Install problem!

Post by RyosukeZ » Mon Mar 05, 2007 8:45 am

Night still need your help for the above post.

New one. Global Announcement
When in the viewforums.php
General Error

Failed obtaining forum access control lists

DEBUG MODE

SQL Error : 1054 Unknown column 'a.auth_globalannounce' in 'field list'

SELECT a.forum_id, a.auth_view, a.auth_read, a.auth_post, a.auth_reply, a.auth_edit, a.auth_delete, a.auth_sticky, a.auth_announce, a.auth_vote, a.auth_pollcreate, a.auth_globalannounce, a.auth_attachments, a.auth_download, a.auth_mod FROM phpbb_auth_access a, phpbb_user_group ug WHERE ug.user_id = 2 AND ug.user_pending = 0 AND a.group_id = ug.group_id AND a.forum_id = 1

Line : 166
File : auth.php
Bored? Come and have fun at my forum!!
Lets rock the hse!!

Locked