Could not obtain EasyMod information when installing mod

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
hsim
Registered User
Posts: 133
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by hsim »

yes thank you very much for trying to help me. As for the permissions, in the database manager it says "This object has all permissions" and I also did "Grant all permissions for (me)" just to be sure.

I'm not sure about what you are asking with the code but I can always try I guess ;)
email me: hsim at gmx.li
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by Nightrider »

If you don't understand how to read php code, it could be very difficult for you to try to debug the code and discover the root of the problem. I would be happy to take a look at it for you if you want, but I may not be able to do it until tomorrow at the earliest. If you are interested, send me a PM and we can go from there...

You can place echo statements in your code to try to discover the contents of variables. In your case, your modified MOD ID doesn't seem to be assigned, thus the SQL statements are failing when trying to update the phpbb_easymod_processed_files table. I doubt that the phpbb_easymod table is being updated either. Can you confirm that???

An echo statement could look like this:

Code: Select all

echo '$mod_id = ' . $mod_id . ' <br />';
A statement like this would display the assignment at the top of the page for variable $mod_id. You can use the echo statement to view the contents of just about any variable, except for an entire array. For arrays, you would have to look at each item in the array...

Image
User avatar
hsim
Registered User
Posts: 133
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by hsim »

I now see “$mod_id =” on the pages.

there is data in the phpbb_easymod table, here is an excerpt:
mod_id mod_title
1
EasyMOD
2
Anti-spam ACP
3
Auto IP Ban Bots(Anti-spam ACP Add-on)
4
Hide users(Anti-spam ACP Add-on)
email me: hsim at gmx.li
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by Nightrider »

Good, so the phpbb_easymod table is being updated each time you install a MOD. So the problem seems to be narrowed down to obtaining the $mod_id created when the MOD record is added to the phpbb_easymod table and using it to create a new record in the phpbb_easymod_processed_files table...

Image
User avatar
hsim
Registered User
Posts: 133
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by hsim »

how can I fix this obtaining the $mod_id?
email me: hsim at gmx.li
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by Nightrider »

Before you can fix it, you have to determine why it is happening. That's why I suggested using the echo statements to see where the mod_id variable should be but is not being assigned. Until you know what is wrong, there won't be a way to fix it...

Image
User avatar
hsim
Registered User
Posts: 133
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by hsim »

Do you have any further hints to track down whatever is wrong?
email me: hsim at gmx.li
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Could not obtain EasyMod information when installing mod

Post by Nightrider »

You have a problem that no one else seems to have or has reported here to my knowledge. So since I have not seen the error before, and you have claimed that the database user permissions are set correctly, I can't even begin to guess what has gone wrong on your site. That's why it is important to pinpoint the problem...

We know, based on your error message, that the MOD ID has not been assigned in the SQL statement that adds a record to your phpbb_easymod_processed_files table. So we need to find out why that is happening before we can come up with a solution. That's why I suggested using echo commands to help pinpoint the cause of the problem...

I've offered personal help and I would be more than happy to figure this out with/for you. Otherwise, you are going to have to go through the EM code yourself. I don't think I will be able to teach you php syntax in a short amount of time. I've been dealing with it for nearly 2 years now and I am still learning it, and I am a trained programmer in other languages...

My offer still stands. If you are interested, send me a PM and we can go from there...

Image
Locked