Installing Attach Mod

Wondering why that MOD you have won't install correctly? Let's take a look
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
simulationcity
Registered User
Posts: 23
Joined: Fri Jul 15, 2005 12:27 am

Installing Attach Mod

Post by simulationcity »

I don't really need the Attach Mod on my forum but when I install the mod it skips parts of the instructions. (I tested Easymod on a second forum just in case) so it didn't matter if it didn't install the mod correctly.)

I know absolutely NOTHING about PHP but is there something I can do to fix this problem?

When it installed the Post Count Control Mod succesfully I got up and waved my arms.
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Installing Attach Mod

Post by Nux »

Attachment MOD isn't compatible (compliant, compilant or whatever ;)) with EM... But still EasyMOD can help a lot in installing this MOD (all the files changes).

If anyone whant to try go ahead: Installing Attachment MOD v2.3.13 with EM
simulationcity
Registered User
Posts: 23
Joined: Fri Jul 15, 2005 12:27 am

Re: Installing Attach Mod

Post by simulationcity »

Will it be made compatible with EM sometime in the future? Because I know nothing about PHP.
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Installing Attach Mod

Post by Nux »

You don't have to know anything about PHP to install Attachment MOD. Just go by the instructions they are really easy if you won't get scared by words MOD and FTP ;).

It took me about 5 minutes(*) to install it :).


(*) And only because I had to read the readme files first.

PS: I doubt that it will become EMC in some near feature, b/c both EMC and Attach would have to change quite a lot.
simulationcity
Registered User
Posts: 23
Joined: Fri Jul 15, 2005 12:27 am

Re: Installing Attach Mod

Post by simulationcity »

I'll try it on a second Test forum. I'm usingg a second forum so that if a mod doesn't install right it doesn't matter.
statm1
Registered User
Posts: 43
Joined: Thu Jul 21, 2005 7:58 am

Re: Installing Attach Mod

Post by statm1 »

Is the Attach Mod 2.3.14 compatible with phpbb 2.0.17?

Because I installed the Attach Mod using EM and it was successful. But afterwards I get this on every page:

Code: Select all

Warning&#58 main(./attach_mod/attachment_mod.php)&#58 failed to open stream&#58 No such file or directory in /home/httpd/vhosts/*******.net/httpdocs/forum/common.php on line 451

Warning&#58 main(./attach_mod/attachment_mod.php)&#58 failed to open stream&#58 No such file or directory in /home/httpd/vhosts/*******.net/httpdocs/forum/common.php on line 451

Warning&#58 main()&#58 Failed opening './attach_mod/attachment_mod.php' for inclusion (include_path='.&#58/usr/share/pear') in /home/httpd/vhosts/*******.net/httpdocs/forum/common.php on line 451

Fatal error&#58 Call to undefined function&#58 include_attach_lang() in /home/httpd/vhosts/*******.net/httpdocs/forum/includes/functions.php on line 579
Any help would be greatly appreciated.
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Installing Attach Mod

Post by Nux »

You don't have this file: attach_mod/attachment_mod.php or maybe even the whole directory. This means that the installations wasn't completed successfully. I'll check it with 2.0.17 at some later time.
statm1
Registered User
Posts: 43
Joined: Thu Jul 21, 2005 7:58 am

Re: Installing Attach Mod

Post by statm1 »

Ok.. It was my fault for just assuming that EM was right in saying the installation was sucessful.. I had to manually move all the files and after I did that its fine now.. Thank you for your help.
zimnick
Registered User
Posts: 1
Joined: Fri Aug 22, 2003 9:26 pm
Contact:

Re: Installing Attach Mod

Post by zimnick »

##############
Nevermind, I figured it out :)

Please delete this post!
luvs2play_
Registered User
Posts: 6
Joined: Mon Aug 22, 2005 1:20 am

Re: Installing Attach Mod

Post by luvs2play_ »

I just finished adding the attach mod but when I click on the link for Allowed Extensions and Sizes I get a General error message that says:
You are not allowed to call this file (ID:2)

when I try to upload a gif or a jpg I get the following:
This is just a test to check and see if the attachment feature is working correctly.

Any help in resolving these issues would be greatly appreciated, thank you in advance.

Renee
Locked