Localhost Problem?

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
Train
Registered User
Posts: 3
Joined: Tue Jul 15, 2008 7:29 pm

Localhost Problem?

Post by Train » Tue Jul 15, 2008 7:38 pm

OKay I don't know what to do for this:

Code: Select all

Testing selected write method
Testing FTP access...

FTP ERROR: connection to localhost:21 failed.
This error occurs frequently, particularly on hosts like Lycos. Back on step 1 you should try changing the FTP Server from "localhost" to whatever hostname you typically use when you FTP.
What to do?

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Localhost Problem?

Post by Lumpy Burgertushie » Tue Jul 15, 2008 8:35 pm

Train wrote:OKay I don't know what to do for this:

Code: Select all

Testing selected write method
Testing FTP access...

FTP ERROR: connection to localhost:21 failed.
This error occurs frequently, particularly on hosts like Lycos. Back on step 1 you should try changing the FTP Server from "localhost" to whatever hostname you typically use when you FTP.
What to do?
exactly what the error message tells you to do.


robert

User avatar
Train
Registered User
Posts: 3
Joined: Tue Jul 15, 2008 7:29 pm

Re: Localhost Problem?

Post by Train » Wed Jul 16, 2008 5:56 am

But "localhost" is what I use! :(

User avatar
WhiteWolfSix
Registered User
Posts: 210
Joined: Fri Jan 21, 2005 9:05 am
Location: 48°43′N, 19°08′E

Re: Localhost Problem?

Post by WhiteWolfSix » Wed Jul 16, 2008 4:30 pm

Check your hosting again. This information could be available on their website in FAQ or wherever else.
Image
WhiteWolfSix (WW6)

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Localhost Problem?

Post by Lumpy Burgertushie » Thu Jul 17, 2008 2:47 am

I believe that the "localhost" variable will use your domain name for the ftp server.
on some hosts, this is not correct.
basically, whatever you have to put into your ftp program for the server name is what should go in that box when installing.

robert

User avatar
Train
Registered User
Posts: 3
Joined: Tue Jul 15, 2008 7:29 pm

Re: Localhost Problem?

Post by Train » Sun Jul 20, 2008 5:53 pm

Now this appers:

Permissions: (including system errors)
read access :: OK
write access :: OK
root path write :: No
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: No
FTP extension :: OK
Safe Mode :: ON
copy access :: No


Additional System Information:

System: Linux localhost.localdomain 2.6.18-92.1.6.el5 #1 SMP Wed Jun 25 13:49:24 EDT 2008 i686
Configure Command: './configure' '--enable-memory-limit' '--disable-debug' '--with-regex=php' '--disable-rpath' '--disable-static' '--with-pic' '--with-layout=GNU' '--with-pear=/usr/share/php' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-db4' '--with-iconv' '--enable-exif' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-mbstring' '--with-pcre-regex=/usr' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--disable-xml' '--with-expat-dir=/usr' '--with-xmlrpc' '--enable-yp' '--enable-dio' '--with-zlib' '--without-pgsql' '--with-kerberos=/usr' '--with-openssl=/usr' '--with-zip=/usr' '--enable-dbx' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-exec-dir=/usr/lib/php4/libexec' '--prefix=/usr' '--with-apxs2=/usr/bin/apxs2' '--with-config-file-path=/etc/php4/apache2' '--with-jpeg-dir=/usr/lib' '--with-gd' '--with-curl' '--with-mysql'
PHP version: 5.1.6
register_globals: OFF
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: OFF
sockets_support: enabled


Recommendations:
write: server
move: automated FTP

Selected settings:
write: ftpb
move: ftpa
ftp dir: apateezer.vndv.com
ftp host: apateezer.vndv.com
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x templates
-rwxr-xr-x modx_inside.png
drwxr-xr-x includes
-rwxrwx--- easymod_display_functions.php
-rwxr-xr-x easymod.gif
-rwxrwx--- easymod_install.php
drwxr-xr-x ..
drwxrwx--- em_includes
drwxr-xr-x languages
drwxrwx--- .
Testing FTP access...
Trying to connect to apateezer.vndv.com:21 ...
Error : Cannot connect to remote host "apateezer.vndv.com:21"
Error : fsockopen() ()

FTP ERROR: connection to apateezer.vndv.com:21 failed.
This error occurs frequently when the port number is incorrect. Back on step 1 you should try changing the FTP Port from 21 to whatever port you typically use when you FTP.

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Localhost Problem?

Post by Lumpy Burgertushie » Tue Jul 22, 2008 1:35 am

ok, when using your ftp program to connect to your server, what do you put in the server name box?
is it:
apateezer.vndv.com

exactly like that?

what do you put in the port box? is it: 21?

whatever information you use to connect using your ftp program is what you have to put in the easymod install form.

it has to be EXACTLY the same.

robert

Locked