critical error...extension.inc

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
ethansmomma
Registered User
Posts: 4
Joined: Sun May 04, 2008 5:05 pm

critical error...extension.inc

Post by ethansmomma » Sun May 04, 2008 5:08 pm

CRITICAL ERROR: the file 'extension.inc' could not be found. Please, make sure EasyMOD has been uploaded under the admin/mods/easymod/ directory of your phpBB installation.

what do you recommend?

Realisty
Registered User
Posts: 107
Joined: Sat Jan 20, 2007 3:37 pm

Re: critical error...extension.inc

Post by Realisty » Sun May 04, 2008 5:54 pm

I would suggest to re-upload to see if that fixes the problem.

ethansmomma
Registered User
Posts: 4
Joined: Sun May 04, 2008 5:05 pm

Re: critical error...extension.inc

Post by ethansmomma » Sun May 04, 2008 6:34 pm

i copied the easymod_0.3.0 file over, so i corrected it by just copying the easymod file over.

dbetanco
Registered User
Posts: 2
Joined: Tue Aug 05, 2008 11:53 pm

Re: critical error...extension.inc

Post by dbetanco » Wed Aug 06, 2008 12:00 am

hi!
I have installted 3.00 and also tried using lastest version.
this message:
CRITICAL ERROR: the file 'extension.inc' could not be found. Please, make sure EasyMOD has been uploaded under the admin/mods/easymod/ directory of your phpBB installation.
When I tried to install executing
admin/mods/easymod/easymod_install.php

I search inside the zip file and there is no EXTENSION.INC there!!!

And also check the php file:
define('IN_PHPBB', 1);
$phpbb_root_path = '../../../';

// Checking phpBB files here allow us to halt installation and warn them with an explanation if the have not upload EM to the correct place ;-)
if( !@file_exists($phpbb_root_path . 'extension.inc') )
{
// display error message (obviously we can't use the lang system from this ;-)
echo "<b>CRITICAL ERROR:</b> the file 'extension.inc' could not be found. Please, make sure EasyMOD has been uploaded under the admin/mods/easymod/ directory of your phpBB installation.\n";
exit;
}
// Note using require rather than include makes sense, since we can't really proceed if the files are not available.
require($phpbb_root_path . 'extension.inc');
require($phpbb_root_path . 'common.'.$phpEx);
require($phpbb_root_path . 'includes/functions_admin.'.$phpEx);


So......????????????? There is an error in the installer?

Realisty
Registered User
Posts: 107
Joined: Sat Jan 20, 2007 3:37 pm

Re: critical error...extension.inc

Post by Realisty » Thu Aug 07, 2008 10:59 am

easymod is for phpbb version 2.x and not for 3.x ;)

dbetanco
Registered User
Posts: 2
Joined: Tue Aug 05, 2008 11:53 pm

Re: critical error...extension.inc

Post by dbetanco » Fri Aug 08, 2008 1:38 am

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
i´ll test rigth now!

really tks! I have been looking around this for the 3 months =)

Locked