Critical error help

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
SirNik
Registered User
Posts: 4
Joined: Mon Mar 24, 2008 8:38 am

Critical error help

Post by SirNik » Mon Mar 24, 2008 8:43 am

I keep getting this message even though I know I uploaded it like instructed
CRITICAL ERROR: the file 'admin/mods/easymod/em_includes/em_ftp.php' could not be found. Please, make sure EasyMOD has been uploaded under the admin/mods/easymod/ directory of your phpBB installation

User avatar
WhiteWolfSix
Registered User
Posts: 210
Joined: Fri Jan 21, 2005 9:05 am
Location: 48°43′N, 19°08′E

Re: Critical error help

Post by WhiteWolfSix » Mon Mar 24, 2008 2:16 pm

Check whether the file you uploaded isn't corrupted. It happens sometimes, be careful using ANSI mod (not binary) while ftp transfer.
Image
WhiteWolfSix (WW6)

SirNik
Registered User
Posts: 4
Joined: Mon Mar 24, 2008 8:38 am

Re: Critical error help

Post by SirNik » Mon Mar 24, 2008 11:00 pm

I dont understand Ansi or binary what are they

SirNik
Registered User
Posts: 4
Joined: Mon Mar 24, 2008 8:38 am

Re: Critical error help

Post by SirNik » Mon Mar 24, 2008 11:16 pm

This is what I got when trying to install EasyMod
Progress :: . Done
Result :: Some queries failed, the statements and errors are listing below
Error :: Table 'phpbb_2.phpbb_easymod' doesn't exist
SQL :: INSERT INTO phpbb_easymod ( mod_title, mod_file, mod_version, mod_author_handle, mod_author_email, mod_author_name, mod_author_url, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited, mod_tables_added, mod_tables_altered, mod_rows_inserted) VALUES ( 'EasyMOD', 'easymod/easymod_install.php', '0.3.0', 'Nuttzy', 'pktoolkit@blizzhackers.com', 'n/a', 'http://www.blizzhackers.com', 'EasyMOD automatically perfoms in seconds which previously required the tedious task of manually editing files.', 1206399894, '2.0.18', 'subSilver; extremedarkred', 'english', 0, 1, 0, 1)

Could not successfully update table. Something is wrong and install cannot complete.


Debug info:

formatted for forum posting)
EM installer v0.3.0 wrote: Update EM from: 0.3.0
phpBB version: 2.0.18
Working Dir: /KHboard/admin/mods/easymod
Install Step: 2
Mode: debug

The Error wrote: No error.

Permissions: (including system errors)

read access :: OK
write access :: OK
root path write :: OK
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: No
FTP extension :: module not loaded
Safe Mode :: OFF
copy access :: OK


Additional System Information:

System: FreeBSD hostingprod.com 4.11-YAHOO-20070423 FreeBSD 4.11-YAHOO-20070423 #0: i386
Configure Command: './configure' '--prefix=/usr' '--enable-fastcgi' '--with-config-file-path=/usr/lib/php' '--enable-memory-limit' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-mbstring=all' '--enable-mbregex' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-gdbm' '--with-gettext' '--with-iconv' '--with-gd' '--with-jpeg-dir' '--with-png-dir' '--with-tiff-dir' '--with-xpm-dir=/usr/X11R6' '--with-zlib-dir' '--with-ttf' '--with-freetype-dir' '--with-t1lib' '--enable-gd-native-ttf' '--with-mcrypt' '--with-mhash' '--with-mime-magic' '--with-ming' '--with-openssl' '--with-pspell' '--with-regex' '--enable-wddx' '--with-xmlrpc' '--enable-xslt' '--with-xslt-sablot' '--with-zip' '--disable-posix'
PHP version: 4.3.11
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: N/A


Recommendations:
write: server
move: copy

Selected settings:
write: server
move: copy
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxrwxr-x . 
drwxrwxr-x .. 
-rw-rw-r-- easymod.gif 
-rw-rw-r-- easymod_display_functions.php 
-rw-rw-r-- easymod_install.php 
drwxrwxr-x em_includes 
drwxrwxr-x includes 
drwxrwxr-x languages 
drwxrwxr-x templates 
-rwxrwxrwx post_process.sh 
-rwxrwxrwx post_process.bat 

Not testing FTP since it is not being used.

User avatar
WhiteWolfSix
Registered User
Posts: 210
Joined: Fri Jan 21, 2005 9:05 am
Location: 48°43′N, 19°08′E

Re: Critical error help

Post by WhiteWolfSix » Tue Mar 25, 2008 7:23 am

Please, don't make a double posts! I have replied you in your other topic.
Image
WhiteWolfSix (WW6)

fitnfree
Registered User
Posts: 4
Joined: Tue Apr 22, 2008 12:54 pm

Re: Critical error help

Post by fitnfree » Tue Apr 22, 2008 12:59 pm

I am also getting a critical error telling me I do not have the "extension.inc" file -- this is driving me batty. I did everything as instructed...uploaded it into the adm folder in a folder titled "mods", etc. I even re-downloaded phpBB 3.0 and searched through all the files trying to find this extension.inc. Been at this for 3 days now and am lost.

I don't know PHP and could really use this mod to work. I know it says it's still in BETA; is that why it is unusable but if so, why does it appear others are able to utilize it? Thanks.


Wait a minute, I'm soooo sorry, i see this is for EasyMOD for 2.0 -- I need 3.0 help! I can't find a way to delete this. I'm really sorry.

Realisty
Registered User
Posts: 107
Joined: Sat Jan 20, 2007 3:37 pm

Re: Critical error help

Post by Realisty » Tue Apr 22, 2008 4:21 pm

There is no easymod for phpbb 3 ....although there is development for something like that for phpbb 3 .... but it is not certain when that will be finished ;)

Locked