Having trouble

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Guts4x4
Registered User
Posts: 4
Joined: Sun Jan 20, 2008 11:19 am

Having trouble

Post by Guts4x4 » Sun Jan 20, 2008 11:26 am

Now before you reply please keep your talk real simpal as I'm all most a dummie when it comes to pc's.

I have down loaded easy mod to my pc
then uploaded it to my server
then when I open the install file I get this,


// Checking phpBB files here allow us to halt installation and warn them with an explanation if the have not upload EM to the correct place ;-)

if( !@file_exists($phpbb_root_path . 'extension.inc') )

{

// display error message (obviously we can't use the lang system from this ;-)

echo "<b>CRITICAL ERROR:</b> the file 'extension.inc' could not be found. Please, make sure EasyMOD has been uploaded under the admin/mods/easymod/ directory of your phpBB installation.\n";

exit;

}

// Note using require rather than include makes sense, since we can't really proceed if the files are not available.

require($phpbb_root_path . 'extension.inc');

require($phpbb_root_path . 'common.'.$phpEx);

require($phpbb_root_path . 'includes/functions_admin.'.$phpEx);

Guts4x4
Registered User
Posts: 4
Joined: Sun Jan 20, 2008 11:19 am

Re: Having trouble

Post by Guts4x4 » Sun Jan 20, 2008 11:27 am

This is the file location on my server

file://4x4alburywodonga.com/forum/admin/mods/easymod - dir(s):4 | file(s):3

User avatar
WhiteWolfSix
Registered User
Posts: 210
Joined: Fri Jan 21, 2005 9:05 am
Location: 48°43′N, 19°08′E

Re: Having trouble

Post by WhiteWolfSix » Sun Jan 20, 2008 12:36 pm

Try to re-up all files belonging to EasyMOD.
Image
WhiteWolfSix (WW6)

Guts4x4
Registered User
Posts: 4
Joined: Sun Jan 20, 2008 11:19 am

Re: Having trouble

Post by Guts4x4 » Sun Jan 20, 2008 9:31 pm

I have re down loaded them and re up loaded them and still it does not work.
I'm logged in to both my forum and my server as admin and still nothing grrrr
I thought these types of help BB's were here to help people willing to have a go that don't know and fully understand all the pc mumbo jumbo.
Whats the use of having these BB's for people that allready know how to do this stuff?

How about helping out somebody that doesn't know about this stuff but that is more then willing to have a go and learn.

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Having trouble

Post by Lumpy Burgertushie » Mon Jan 28, 2008 4:42 pm

Guts4x4 wrote:I have re down loaded them and re up loaded them and still it does not work.
I'm logged in to both my forum and my server as admin and still nothing grrrr
I thought these types of help BB's were here to help people willing to have a go that don't know and fully understand all the pc mumbo jumbo.
Whats the use of having these BB's for people that allready know how to do this stuff?

How about helping out somebody that doesn't know about this stuff but that is more then willing to have a go and learn.
how about calming down a bit. you have asked for help and were given the common advice when people are having a problem.

the things that you posted above are not what you should be seeing in your browser when you have properly uploaded the files or when your server is properly setup to be able to do this.

we have to find out why you are seeing the php code from the install file instead of what the php file is supposed to be doing.

It looks like all the files are uploaded now and in the correct places.

try this, get a fresh copy of the latest version of easymod, unzip it to your computer.

now, upload a brand new copy of easymod_install.php.

do not open any of the files with anything other than a text editor like notepad or wordpad etc.

do not use anything other than a real ftp program to upload/download these files.

things like your hosting control panel file manager and /or file editor sometimes corrupt php files.

luck,
robert

Guts4x4
Registered User
Posts: 4
Joined: Sun Jan 20, 2008 11:19 am

Re: Having trouble

Post by Guts4x4 » Fri Feb 01, 2008 12:59 am

I worked all this out with help from one mate who showed me where I was going wrong.

For starters you DON'T open the file with note pad or anything else. Saying this only adds confusion for NONE pc people.

Here is how I added easymod.
Download file to comp, did this first up without any problems
Upload it to server with FTP program. Did this first up without any problems. Worked out how to do all this just from reading how to questions.
Then go in to server and copy and paste the file name to your browser, this is where I was going wrong because I was trying to open the file with note pad and copy it. You don't infact open the bloody file at all. You just copy and paste its name and location to the browser as if you were going to open a web site. Then its all follow the instructions.

Adding anti spam was then as easy as following the instruction that come up in the easymod section that now shows up in your admin section on your forum.

Since then I have worked out how to add smilies and change the order in which they show up in the smile window on the reply page.

User avatar
Lumpy Burgertushie
Registered User
Posts: 1006
Joined: Tue Feb 28, 2006 5:26 pm

Re: Having trouble

Post by Lumpy Burgertushie » Fri Feb 01, 2008 10:40 pm

Guts4x4 wrote:I worked all this out with help from one mate who showed me where I was going wrong.

For starters you DON'T open the file with note pad or anything else. Saying this only adds confusion for NONE pc people.

Here is how I added easymod.
Download file to comp, did this first up without any problems
Upload it to server with FTP program. Did this first up without any problems. Worked out how to do all this just from reading how to questions.
Then go in to server and copy and paste the file name to your browser, this is where I was going wrong because I was trying to open the file with note pad and copy it. You don't infact open the bloody file at all. You just copy and paste its name and location to the browser as if you were going to open a web site. Then its all follow the instructions.

Adding anti spam was then as easy as following the instruction that come up in the easymod section that now shows up in your admin section on your forum.

Since then I have worked out how to add smilies and change the order in which they show up in the smile window on the reply page.
good work!!

you kept at it until you figured it out.


you can open any php file in notepad or wordpad and it won't hurt them.

however, as you said,when installing easymod, there is no reason to open any of the files.

robert

Locked