Huge problem installing Easymod - Help for a newbie!

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
BrandonG
Registered User
Posts: 2
Joined: Wed Aug 01, 2007 10:52 pm

Huge problem installing Easymod - Help for a newbie!

Post by BrandonG »

1) First of all I choose
"I have FTP Access to my phpBB files on my server"

At this stage my file access info reads as follows

read access :: OK
write access :: No
root path write :: No
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: No

I see write access and copy access is off, being a noob I don't know why..

So then I input the following, I do not have a forum section (eg. public_html/phpBB)
it simply goes public_html/admin and thats where my files are stored,
if I try and put them in a folder name "phpBB" or "forum" it simply does not work if I do that

I leave it as "public_html" as thats where my files are stored as I stated earlier and the
port stays at 21.
I'm thinking the problem could be at this stage I put in an email for an FTP which is linked
to a folder called "joebloggs" as the email is "joebloggs@mydomain.com"
I say yes for FTP Debug Mode, yes for PHP FTP Extension and no for Use FTP Cache

Image

(2)
So I then Set and confirm my EM password, and press submit.
The results are in the screenie below, the problem is that it's saying my directory is /, but
if I try and put it as that instead of just "public_html", it doesn't work anyway

Code: Select all

(formatted for forum posting)

[quote="EM installer v0.3.0"]
[b]EM status:[/b] New Install
[b]phpBB version:[/b] 2.0.22
[b]Working Dir:[/b] /home/fiverfoo/public_html/admin/mods/easymod
[b]Install Step:[/b] 2
[b]Mode:[/b] debug


[quote="The Error"]
[color=green][b]No error.[/b][/color]
[/quote]


[b]Permissions:[/b] (including system errors)

read access  ::  [b][color=green]OK[/color][/b] 
write access  ::  [b]No[/b] 
root path write  ::  [b]No[/b] 
chmod access  ::  unattempted 
unlink access  ::  unattempted 
mkdir access  ::  unattempted 
tmp path write  ::  [b][color=green]OK[/color][/b] 
FTP extension  ::  [b][color=green]OK[/color][/b] 
Safe Mode  ::  [b][color=green]OFF[/color][/b] 
copy access  ::  [b]No[/b] 


[b]Additional System Information:[/b]

[b]System:[/b] Linux server.iwhic.com 2.6.9-55.0.2.ELsmp #1 SMP Tue Jun 26 14:30:58 EDT 2007 i686
[b]Configure Command:[/b] './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-zlib'
[b]PHP version:[/b] 4.4.7
[b]register_globals:[/b] ON
[b]magic_quotes_gpc:[/b] ON
[b]magic_quotes_runtime:[/b] OFF
[b]allow_url_fopen:[/b] ON
[b]sockets_support:[/b] enabled


[b]Recommendations:[/b]
[b]write:[/b] buffer & ftp
[b]move:[/b] automated FTP

[b]Selected settings:[/b]
[b]write:[/b] ftpb
[b]move:[/b] ftpa
[b]ftp dir:[/b] public_html
[b]ftp host:[/b] 69.59.25.9
[b]ftp port:[/b] 21
[b]ftp debug:[/b] false
[b]ftp ext:[/b] ext
[b]ftp cache:[/b] false

[b]CWD Listing:[/b]
[code]
drwxr-xr-x . 
drwxr-xr-x languages 
-rw-r--r-- easymod_install.php 
drwxr-xr-x includes 
-rw-r--r-- easymod.gif 
-rw-r--r-- easymod_display_functions.php 
drwxr-xr-x templates 
drwxr-xr-x em_includes 
drwxr-xr-x .. 
Testing FTP access...
1) Logged in successfully
Current Working Directory: /
Directory listing: (0 files being listed)

FTP ERROR: could not cd to public_html
You successfully logged into the server, but could not change direcory (CD) to the easymod directory. The following is recommended:



Are you sure you entered the correct path? Below is a directory listing of the files in the FTP root directory. The FTP root directory is simply the starting point when you connect. The path to the phpBB2 installation should begin with one of the directory names listed below.
Directory names are case sensitive. Be sure the easymod directory is all lowercase.
In some *very rare* cases it's possible that you are not connecting to the proper FTP Server. Try specifying the hostname in the FTP Server field and the port in the FTP Port field.
Some servers have issues with the passive mode that EasyMOD attempts to use by default. If you have the PHP FTP extension loaded, then enable that option in step 1.

FTP root directory:
/


Directory listing: your FTP Path should start with one of the directories listed below
FTP Error: A file listing could not be obtained. This usually indicates solution 4 listed above.


I will be internally grateful for anyhelp recieved, I'm pretty much a newbie to this kind of stuff so any basic help appreciated.

BrandonG
Registered User
Posts: 2
Joined: Wed Aug 01, 2007 10:52 pm

Re: Huge problem installing Easymod - Help for a newbie!

Post by BrandonG »

Would it be anything to do with extensions.inc? I can't seem to find that.. where should that be?

Locked