Reinstalling EasyMod

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
SMITH060
Registered User
Posts: 2
Joined: Sun Jul 29, 2007 5:33 am

Reinstalling EasyMod

Post by SMITH060 »

Hello. I am having some troubles reinstalling EasyMod. I know that I need to change the version in the ACP to an earlier version and I would if I could. This is the error message and it is there because I've had to revert to the backup files after a critical error with installing the SubForums modification...

Here is the error message when I click on any of the EasyMod links in the ACP:

Code: Select all

Template->make_filename(): Error - file admin/mod_header.tpl does not exist
I understand that this is basically telling me what is wrong, but I don't know how to fix this.

I also tried removing all the files related so that it didn't give me this error message, and so that I could basically start over with the installation:
Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.
The link is no longer valid for the EM Version Changer.

I am obviously not smart enough to figure out how to completely remove it, and cannot seem to figure out how to fix my little problem. I would appreciate any help I could get, all I need is a simple answer to this simple question. I know how to reinstall it, but I don't know how to fix it so that I can regain access to the settings in the ACP.

Please help.
User avatar
Poomerio
Registered User
Posts: 552
Joined: Tue Jan 02, 2007 7:09 pm
Location: 4(x - 20y) = 20

Re: Reinstalling EasyMod

Post by Poomerio »

OK, there is two ways of doing this.
I'm going to show you how to change the version number to be able to install EasyMOD (it's the easiest)

You could change the version number.

Enter into your phpMyAdmin
Open the table phpbb_config
Browse for the field EM_version
Edit the value, and just change the version number
Reinstall EasyMOD

This makes EasyMOD think that it is old, therefore it will let you install a "newer" version.

- Poomie
Locked