Missing files everywhere -- solved

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
hunkychop
Registered User
Posts: 6
Joined: Wed Feb 28, 2007 1:23 am

Missing files everywhere -- solved

Post by hunkychop »

well, i am using 110mb.com since i am having static IP issues with my ISP, but anyway...

FTP wasnt working so i decided to use the generate script for moving files.

It has been a nightmare, ive never had this kind of problem installing easymod before.

about 10 files ended up not getting moved so i did all of those manualy... but, when all was said and done, and easymod said it was done. i went to install some mods and i get...

Code: Select all

phpBB : Critical Error 

Could not locate valid language pack 
i only get that in the easymod section of the admin panel

i copyed all of the language packs that went missing but it still gives me this error. Any ideas?
Last edited by hunkychop on Thu Mar 01, 2007 10:32 pm, edited 2 times in total.
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Missing files everywhere

Post by Nightrider »

I believe that is a phpBB error when the default language files are missing in the language folder. Did you accidentally move or delete your default lang_xxx folder or it's contents; i.e. lang_english???

Image
hunkychop
Registered User
Posts: 6
Joined: Wed Feb 28, 2007 1:23 am

Re: Missing files everywhere

Post by hunkychop »

I didnt get any errors before in php,

no, i didnt

everything else works fine

edit
i checked and all of the easy mod language files where right where they are supposed to be ( if the root language folder is correct)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Missing files everywhere

Post by Nightrider »

This error orginates in phpBB's includes/functions.php file when it checks to see that the lang_main.php file exists in the language that you are using. This problem is not related to the EM install though. So first determine what language is currently assigned to you, then make sure the lang_xxxx/lang_main.php file exists, where lang_xxxx represents the language folder that you are using...

Image
hunkychop
Registered User
Posts: 6
Joined: Wed Feb 28, 2007 1:23 am

Re: Missing files everywhere

Post by hunkychop »

everything is in place...

also, i just noticed that when you click on a topic, instead of the post you get a debug error.

i am in the process of creating a new version of my site and heres the link to the page that shows the debug error:

http://tckiwanis.110mb.com/l/viewtopic.php?t=3

i dont know how the ranks table got deleted, i didnt to any manual sql editing
i can create a new one but i dont know how many collums are in the phpbb_ranks table
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Missing files everywhere -- unsolved

Post by Nightrider »

Here is the SQL code to recreate your Ranks table. If that is missing, I wonder what else is gone as well???

Code: Select all

CREATE TABLE `phpbb_ranks` (
  `rank_id` smallint(5) unsigned NOT NULL auto_increment,
  `rank_title` varchar(50) NOT NULL default '',
  `rank_min` mediumint(8) NOT NULL default '0',
  `rank_special` tinyint(1) default '0',
  `rank_image` varchar(255) default NULL,
  PRIMARY KEY  (`rank_id`)
) TYPE=MyISAM;
I'm taking off for a few hours, so hopefully this will be enough to get your forum up and running again until I get back...

Image
hunkychop
Registered User
Posts: 6
Joined: Wed Feb 28, 2007 1:23 am

Re: Missing files everywhere -- unsolved

Post by hunkychop »

that got my forum back on line but i am still having easymod language issues. thanks for the help though
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Missing files everywhere -- unsolved

Post by Nightrider »

You're not giving me a lot to go by, so I'm guessing at that perhaps your lang_easymod.php file in your languages/lang_english folder is misnamed lang_easymod_english.php file. That typically happens when EM is manually installed. If that is the case, simply remove the _english part from the filename...

Image
hunkychop
Registered User
Posts: 6
Joined: Wed Feb 28, 2007 1:23 am

Re: Missing files everywhere -- unsolved

Post by hunkychop »

yeah, i noticed that earlier and changed it to lang_easymod.php

still, no resolve

is there a way i can remove easymod and install a new one.

the file may have been corrupted. I am using a css edit of the phpbblite theme and the creaters included a series of mods pre extrated into the mod file (including easymod)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Missing files everywhere -- unsolved

Post by Nightrider »

You don't have to remove EM in order to reinstall it. All you need to do is decrease the EM version, then do the EM install again. If you think there might have been a file corruption problem, make sure to upload a fresh copy of the EM install files to admin/mods before you start the reinstall...

EM Version Change

Before you can reinstall EM, you need to decrease the EM version number in your phpbb_config table...
  • EM Version Change Option 1

    I created this DB Update file that you can run from your browser. Download and unzip the following file, then upload it to your phpBB root and run it from your browser:

    em_db_decrease_version.zip

    The path to the unzipped file might look something like this in your browser:

    Code: Select all

    http://yourdomain.com/forum/em_db_decrease_version.php
  • EM Version Change Option 2

    If you already had EM 0.3.0 installed, then you will need to change the EM Version back so that the install will think that this is an Upgrade. You can use this tool to change your EM Version so that you can reinstall EM on your board:

    EM_Version_Changer

    Once the EM Version Changer is installed, set the EM version to 0.1.13 or 0.2.0...
  • EM Version Change (Manual Option 3)

    If you want to manually change the EM version, you can do so in your phpbb_config table. Just look for the record beginning with EM_version. Then you can change the related field to 0.1.13. You could also delete all the records in the phpbb_config table that begin with EM_ and delete the phpbb_easymod table too to have the new install recreate everything...
Image
Locked