So I get require(../includes/sql/sql_parser.php) ..?

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
ocken
Registered User
Posts: 1
Joined: Wed Feb 07, 2007 10:58 am

So I get require(../includes/sql/sql_parser.php) ..?

Post by ocken » Wed Feb 07, 2007 11:26 am

Hello

I'm no phpBB expert and could sure need some assistance.

I get this message when I try to install some mods.

Code: Select all

Warning: require(../includes/sql/sql_parser.php): failed to open stream: No such file or directory in /apache/htdocs/studorg/uars/phpBB2/admin/admin_easymod.php on line 3030
I recently upgraded from 2.0.20 to 2.0.22, does that mean I have to re-install EasyMod or is there something I'm missing? I've checked and the file structure is correct and the file sql_parser.php is in /phpBB2/admin/mods/easymod/includes/sql/.

What do I do wrong?

User avatar
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: So I get require(../includes/sql/sql_parser.php) ..?

Post by Nightrider » Thu Feb 08, 2007 7:24 pm

Yes, you should probably reinstall EM. It sounds like when you updated, you replaced your old forum files with the udpated files, so you lost the EM files in your includes/sql folder. Once EM is installed, it no longer uses any of the files stored in your admin/mods/easymod folder, so it doesn't matter whether the EM files are found there or not...

EM Version Change

Before you can reinstall EM, you need to decrease the EM version number in your phpbb_config table...
  • EM Version Change Option 1

    I created this DB Update file that you can run from your browser. Download and unzip the following file, then upload it to your phpBB root and run it from your browser:

    em_db_decrease_version.zip

    The path to the unzipped file might look something like this in your browser:

    Code: Select all

    http://yourdomain.com/forum/em_db_decrease_version.php
  • EM Version Change Option 2

    If you already had EM 0.3.0 installed, then you will need to change the EM Version back so that the install will think that this is an Upgrade. You can use this tool to change your EM Version so that you can reinstall EM on your board:

    EM_Version_Changer

    Once the EM Version Changer is installed, set the EM version to 0.1.13 or 0.2.0...
  • EM Version Change (Manual Option 3)

    If you want to manually change the EM version, you can do so in your phpbb_config table. Just look for the record beginning with EM_version. Then you can change the related field to 0.1.13. You could also delete all the records in the phpbb_config table that begin with EM_ and delete the phpbb_easymod table too to have the new install recreate everything...

    phpMyAdmin - Manually Changing the EM Version Number

    The following is how you manually modify your EM password using phpMyAdmin. You can get into your database through your CPanel by clicking on phpMyAdmin. Follow the following instructions:

    I'm sure that every host is different. I will tell you how I run my queries manually and hopefully it will be close to what you have available to you. The following may or may not be similar to what you have...

    Log into your domain Control Panel and find the database icons. You should be able to find the phpMyAdmin icon. Click on it...

    Image

    Hopefully that will log you into your phpAdmin panel. You may need to provide a username and password...

    In the phpMyAdmin panel, click on the Databases hyperlink...

    Image

    Hopefully that should take you where you can select your database. You may only have one. Select your database hyperlink...

    Image

    That should open up the display of all the tables in your database. Ignore them. Somewhere on the page, you should see something similar to this:

    Image

    Click on the phpbb_config table in the Left column navigation bar:

    Image

    Then on the top left of the right window, click on the Browse button:

    Image

    Then to display all the records, change the row settings to 500 starting with record 0, then press the Show button:

    Image

    Scroll down to the EM version field, then click on the little pencil icon next to the record to edit it:

    Image

    Enter the following into the config_value Value editbox. Any version less than your current version will work...

    Code: Select all

    0.1.13
    Image

    Then press the Go button. You should now be able to reinstall EM...

    If you are still unclear on how to do this, send me a PM and I can probably reset your EM version for you...
Image

User avatar
3Di
Registered User
Posts: 686
Joined: Tue Nov 01, 2005 9:50 pm
Location: Milano (I) Frankfurt (D)
Contact:

Re: So I get require(../includes/sql/sql_parser.php) ..?

Post by 3Di » Sat Mar 10, 2007 11:24 pm

Moved from: EM SQL Parser Forum
Want to compensate me for my interest? Don't ask me, just do it
I'm available for custom phpBB jobs, you can PM me the details.
New: my Live Board, Extensions and Tools for phpBB - Men at works.

Locked

Who is online

Users browsing this forum: No registered users and 3 guests