installin simple subforum how to???? help

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
turbojenn
Posts: 14
Joined: Thu Jul 20, 2006 8:43 pm

Re: installin simple subforum how to???? help

Post by turbojenn »

Ok, getting close now...just two errors left:

Code: Select all

Warning

FIND FAILED: In file [templates/iCGstation/overall_header.tpl] could not find:

@import url

MOD script line #904 :: FAQ :: Report
 

Error Detail
 
Warning

FIND FAILED: In file [templates/iCGstation/viewforum_body.tpl] could not find:

<td align="right"><span class="gensmall">{S_AUTH_LIST}</span></td>
</tr>
</table> 
On the view forum error, in iCGstation's viewforum file, this is the closest code I have to match - should I change the FIND to this?:

Code: Select all

<td class="row1" align="right" valign="top"  width="250" nowrap="nowrap"><span class="gensmall">{S_AUTH_LIST}</span></td>
User avatar
turbojenn
Posts: 14
Joined: Thu Jul 20, 2006 8:43 pm

Re: installin simple subforum how to???? help

Post by turbojenn »

ok, on another forum, I found this bit in response to the overall_template issue - does it seem reasonable to edit the .css for the skin?

Code: Select all

 You should add
Quote:
/* Begin Simple Subforums MOD */
a.topic-new, a.topic-new:visited ..

into Jet .css file (at the end). Smile I did that to the AcidTech theme.
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

I knew that import error would come back. So this is what you need to do with it. You will still get a Warning error when EM tries to modify it in the overall_header.tpl code, but you can ignore it this time...

Ok, do this:

OPEN
simple_subforums_1.0.1.txt

This time, we are adding a whole new section to the MOD script which will ONLY modify the iCGstation.css file...

FIND

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/posting_body.tpl
BEFORE ADD - (You are adding this section, and not replacing anything)

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/iCGstation/iCGstation.css


#
#-----[ FIND ]------------------------------------------
#
@import url


#
#-----[ AFTER, ADD ]------------------------------------------
#

/* Begin Simple Subforums MOD */
a.topic-new, a.topic-new:visited { color: {T_BODY_HLINK}; }
a.topic-new:hover, a.topic-new:active { color: {T_BODY_LINK}; }
/* End Simple Subforums MOD */
FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
		<td align="right"><span class="gensmall">{S_AUTH_LIST}</span></td>
	</tr>
</table>
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{S_AUTH_LIST}
</tr>
</table>
You sort of had the right idea, but you forgot that it was FINDing 3 lines instead of one. If you had used what you suggested, you would have placed the code in the wrong place, so be careful...
Save, upload, and try again using EM...

Image
User avatar
turbojenn
Posts: 14
Joined: Thu Jul 20, 2006 8:43 pm

Re: installin simple subforum how to???? help

Post by turbojenn »

OMG - IT WORKS!!! HALLELUJAH! Nightrider, you have made my week, and made managing our forum SO much easier. Thank you so much for all of your help, I am truly in awe of all of the smart, helpful people here willing to help out those of us who are just getting started. THANK YOU!!! :mrgreen:
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Congratulations turbojenn!!! Image

So do you have a fairly good idea of why all of those tricks worked that I suggested? Once you understand some of these easy to learn tricks, you should be able to install even the most difficult MODs in nothing flat...

Image
User avatar
turbojenn
Posts: 14
Joined: Thu Jul 20, 2006 8:43 pm

Re: installin simple subforum how to???? help

Post by turbojenn »

Yeah, I think I understand a lot more about how to install mods now, and will try my hand at installing the merge topics thread this afternoon...I feel *much* more confident in installing now. Thank you for all of your help!!

...There may be hope for me yet in working with php!
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

I have no doubt that you will become a modding expert in no time at all and will be the one helping those who come along after you. It won't take long...

Image
User avatar
turbojenn
Posts: 14
Joined: Thu Jul 20, 2006 8:43 pm

Re: installin simple subforum how to???? help

Post by turbojenn »

I sure hope you are right....the forum has certainly been a boon to the child-welfare non-profit I work for, and is really a wonderful tool to support our families. I would love to learn enough to share what I know with others, and do my part to support the phpBB community!
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

You will be surprised how quickly you can learn this stuff. Once you understand the basics, the rest just kind of makes logical sense. You're off to a good start...

Image
gcds
Posts: 6
Joined: Wed Jul 26, 2006 8:53 am

Re: installin simple subforum how to???? help

Post by gcds »

Hi Nightrider
Can You Help Me with this error:
Here I Have Finished Mod And get This Error look here
here is txt file of templates

Code: Select all

http://n-13.xrgb.net/templates/ca_aphrodite/index_body.tpl.txt
http://n-13.xrgb.net/templates/ca_aphrodite/viewtopic_body.tpl.txt
http://n-13.xrgb.net/templates/ca_aphrodite/viewforum_body.tpl.txt
Please Help
Locked