installin simple subforum how to???? help

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

uhmm i tried as u said it gave me an error like this

Code: Select all

Critical Error

FIND FAILED: In file [templates/subSilver/index_body.tpl] could not find:

<span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td> 
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td> 
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td> 
..

so i tried replacing some in the index_body.tpl file with the idea u gave ddnt work well for me :oops: :oops:
anyway this is my index_body.tpl file

Code: Select all

http://www.gsmlanka.com/avatars/index_body.txt
and why the mod authors have included excess code if they contain errors..i mean...each time we install we gotta change these isnt it:S..anyway thanx in advanced..hey u live in us..so still awakee???? :lol:
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

You're still making progress, so don't get discouraged. The Simple Subforums MOD is a tough MOD to install, so it isn't surprising that it causes a lot of problems for many...

I hope you aren't making any manual modifications to your phpBB files. Just modify the MOD scripts each time you run into a conflict like these...

This is a very tough call on this error message since it is obvious that you have installed another MOD that modified the same section. I have to take an educated guess on this one...

Ok, try this:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
<span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td>


#
#-----[ REPLACE WITH ]------------------------------------------
#
<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
	  <!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
	  <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
	</td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{catrow.forumrow.MODERATORS}
</td>
</tr>
</table>
{catrow.forumrow.TOPICS}
{catrow.forumrow.POSTS}


#
#-----[ REPLACE WITH ]------------------------------------------
#
				<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
	  			<!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
	  			<!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
			</td>
  		</tr>
  	</table></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>
Save, upload, and try again using EM...
shadowcodes wrote: and why the mod authors have included excess code if they contain errors..i mean...each time we install we gotta change these isnt it:S..anyway thanx in advanced..hey u live in us..so still awakee????

Most MOD authors don't know the tricks that can be used to get their MODs to install cleanly when using EM. They should be given a class before submitting their MODs. Still there isn't much they can do to get their MODs to work on updated and modded boards. There's just no way to guess what people will install or how the code will be modified...

Yes, I live in the US and have a very strange sleeping cycle...

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

hey i guessed it should be soo hard..we better name int very hard subforums :lol: :lol:

well this time the errror

Code: Select all

Critical Error

FIND FAILED: In file [index.php] could not find:

while( $category_rows[] = $db->sql_fetchrow($result) ); 
$db->sql_freeresult($result); 
... .. well i live in srilanka.. even i sleep after 3 am :lol:
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

How many hours ahead of us are you? It's after 4 AM here right now. I was thinking of the NSS Simple Subforums MOD (Not So Simple)..

I need a text link to your index.php file...

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

4 am :o well i think im 10 hours ahead of u...man its too late for u ..hehe very much suitable name for u night rider lolzzz


here is my index page..

Code: Select all

http://www.gsmlanka.com/avatars/index.txt
thanx for all
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Yeah, when I worked in the Uranium Mines and when I drove truck, I always preferred the Night shift. Nightrider came from my CB Handle when I was a truck driver many years ago...

Ok, do this:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
while( $category_rows[] = $db->sql_fetchrow($result) );
$db->sql_freeresult($result);
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$category_rows[] = $row;
}
$db->sql_freeresult($result);
Save, upload, and try again using EM...

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

hehe now error lines are getting lesser hehehe: now this is what i get

Code: Select all

FIND FAILED: In file [index.php] could not find:

$category_rows[] = $row; 
} 
$db->sql_freeresult($result); 
$db->sql_freeresult($result); 
im waiting till i complete installing this sub forums. coz i have to install other mods like UCP.. i wanted to complete this and then try that..:)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

It looks like you didn't get the last FIND and REPLACE that I provided quite right. Do you see the duplicated line in your error message???

Code: Select all

$db->sql_freeresult($result); 
$db->sql_freeresult($result);
So you probably need to do this now:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$category_rows[] = $row;
}
$db->sql_freeresult($result);
$db->sql_freeresult($result);
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$category_rows[] = $row;
}
$db->sql_freeresult($result);
Save, upload, and try again using EM...

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

whoooo night rider man thanx alotttt buddy it works:: eeyaayeeeeeeee... oops..uhm now i tested this in ma local pc i.e a windows server..will the same settings work for linux server as well.i planed something like creating a test forum now in my live site and testing this in dat.. with a test db.. if it works i can do the same in my live site what do u say m8????coz does simple forums have any changes between windows and linux hostings?? i read somewhere in a simple forums thread like dat..

cheerzzz
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Congratulations shadowcodes!!! Image

The NSS Simple Subforums should install the same on either Windows or Linux servers. The underlying phpBB code should be identical on either server, so there shouldn't be a problem reinstalling this on another identical board...

Image
Locked