installin simple subforum how to???? help

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

installin simple subforum how to???? help

Post by shadowcodes »

hi guys im new to phpbb i have installed easymod and xs ..please tell me how to install simple subforum with theese two:). thank you.
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

If you haven't done so, read this section: Installing MODs with EasyMOD

If you run into any problems during the MOD install, don't hesitate to ask for additional support. Let me know how it goes..

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

hey i did soo..i wuz coffused coz they told i need xs to install it..i did install with easymod in a windows server..all settings are done in easymod settings for windows server but still i got this error

Code: Select all

Critical Error 

FIND FAILED: In file [admin/admin_forums.php] could not find: 

$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, prune_enable" . $field_sql . ") 
VALUES ('" . $next_id . "', '" . str_replace("\'", "''", $HTTP_POST_VARS['forumname']) . "', " . intval($HTTP_POST_VARS[POST_CAT_URL]) . ", '" . str_replace("\'", "''", $HTTP_POST_VARS['forumdesc']) . "', $next_order, " . intval($HTTP_POST_VARS['forumstatus']) . ", " . intval($HTTP_POST_VARS['prune_enable']) . $value_sql . ")";  
what to do about this
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Often times MOD authors provide far more information than EM needs to FIND a certain line in the file, which limits the number of boards that the MOD will install cleanly on. That is the case with the Simple Sub-Forums MOD too. EM only needs a unique word or phrase to know where to move the file pointer...

So do this:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
			$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, prune_enable" . $field_sql . ")
				VALUES ('" . $next_id . "', '" . str_replace("\'", "''", $HTTP_POST_VARS['forumname']) . "', " . intval($HTTP_POST_VARS[POST_CAT_URL]) . ", '" . str_replace("\'", "''", $HTTP_POST_VARS['forumdesc']) . "', $next_order, " . intval($HTTP_POST_VARS['forumstatus']) . ", " . intval($HTTP_POST_VARS['prune_enable']) . $value_sql . ")";
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE
Save, upload, and try again using EM...

If this doesn't resolve the conflict, I will need a Text link for your admin/admin_forums.php file

Creating text Links for phpBB files

First create a duplicate of the phpBB file on your PC, then rename the file by adding .txt to the end of the file name. Next upload the file to a location on your FTP Server accessible to the public and provide a link back here for us to analyze it...

The path to your file could look something like this now:

Code: Select all

http://yourdomain.com/downloads_folder/admin_forums.txt
Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

hey thanx for the help ..but it gave me some errors again as follows

Code: Select all

Critical Error

IN-LINE FIND FAILED: In file [admin/admin_forums.php] could not find:

intval($HTTP_POST_VARS[POST_CAT_URL])
and here is the text file of my admin_forums.php

Code: Select all

http://www.gsmlanka.com/avatars/admin_forums.txt
atleast if it is asp.net i would have given a try in the code...im a newbie to php.:) sorry to trouble u again..now im heading to bed..will resume with the discussion tomorrow..opps its already morning hehe..

thanx again frend.

cheerz
:D
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Ok, the MOD author pulled a trick that would have worked if the original FIND statement had worked. But since I modified the MOD statement, it changed the flow of the MOD script...

So do this:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE
VALUES
Save, upload, and try again using EM...

Note in the FIND that I iniatially suggested, I told EM to find only ONE line of code in the admin_forums.php file. By adding the keyword VALUES on the second line of the FIND statement, EM will be looking at two lines of the admin_forums.php file which will contain everything EM needs to FIND for the following MOD IN-LINE commands. Also note how little information I had to provide to tell EM what to find. All EM needs is a unique word or phrase from each line of the FIND statement in order to know where to move the file pointer...

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

Code: Select all

Critical Error

FIND FAILED: In file [templates/subSilver/admin/forum_admin_body.tpl] could not find:

<td class="row2"><span class="gen"><a href="{catrow.forumrow.U_VIEWFORUM}" 
now i get this error as shown above.. :? :?
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Ok, now I need a text link to your templates/subSilver/admin/forum_admin_body.tpl file. Do you have other templates installed on your board???

Image
shadowcodes
Posts: 77
Joined: Tue Jul 04, 2006 8:47 am
Contact:

Re: installin simple subforum how to???? help

Post by shadowcodes »

here is the subsilver forum_admin_body

Code: Select all

www.gsmlanka.com/avatars/forum_admin_body.txt
* when i tried to open the text file it displays it as html so i posted the code here also.

forum_admin_body.tpl

Code: Select all

<h1>{L_FORUM_TITLE}</h1>

<p>{L_FORUM_EXPLAIN}</p>

<form method="post" action="{S_FORUM_ACTION}"><table width="100%" cellpadding="4" cellspacing="1" border="0" class="forumline" align="center">
	<tr>
		<th class="thHead" colspan="7">{L_FORUM_TITLE}</th>
	</tr>
	<!-- BEGIN catrow -->
	<tr>
		<td class="catLeft" colspan="3"><span class="cattitle"><b><a href="{catrow.U_VIEWCAT}">{catrow.CAT_DESC}</a></b></span></td>
		<td class="cat" align="center" valign="middle"><span class="gen"><a href="{catrow.U_CAT_EDIT}">{L_EDIT}</a></span></td>
		<td class="cat" align="center" valign="middle"><span class="gen"><a href="{catrow.U_CAT_DELETE}">{L_DELETE}</a></span></td>
		<td class="cat" align="center" valign="middle" nowrap="nowrap"><span class="gen"><a href="{catrow.U_CAT_MOVE_UP}">{L_MOVE_UP}</a> <a href="{catrow.U_CAT_MOVE_DOWN}">{L_MOVE_DOWN}</a></span></td>
		<td class="catRight" align="center" valign="middle"><span class="gen">&nbsp;</span></td>
	</tr>
	<!-- BEGIN forumrow -->
	<tr> 
		<td class="row2"><span class="gen">{catrow.forumrow.FORUM_ICON_IMG}&nbsp;&nbsp;<a href="{catrow.forumrow.U_VIEWFORUM}" target="_new">{catrow.forumrow.FORUM_NAME}</a></span><br /><span class="gensmall">{catrow.forumrow.FORUM_DESC}</span></td>
		<td class="row1" align="center" valign="middle"><span class="gen">{catrow.forumrow.NUM_TOPICS}</span></td>
		<td class="row2" align="center" valign="middle"><span class="gen">{catrow.forumrow.NUM_POSTS}</span></td>
		<td class="row1" align="center" valign="middle"><span class="gen"><a href="{catrow.forumrow.U_FORUM_EDIT}">{L_EDIT}</a></span></td>
		<td class="row2" align="center" valign="middle"><span class="gen"><a href="{catrow.forumrow.U_FORUM_DELETE}">{L_DELETE}</a></span></td>
		<td class="row1" align="center" valign="middle"><span class="gen"><a href="{catrow.forumrow.U_FORUM_MOVE_UP}">{L_MOVE_UP}</a> <br /> <a href="{catrow.forumrow.U_FORUM_MOVE_DOWN}">{L_MOVE_DOWN}</a></span></td>
		<td class="row2" align="center" valign="middle"><span class="gen"><a href="{catrow.forumrow.U_FORUM_RESYNC}">{L_RESYNC}</a></span></td>
	</tr>
	<!-- END forumrow -->
	<tr>
		<td colspan="7" class="row2"><input class="post" type="text" name="{catrow.S_ADD_FORUM_NAME}" /> <input type="submit" class="liteoption"  name="{catrow.S_ADD_FORUM_SUBMIT}" value="{L_CREATE_FORUM}" /></td>
	</tr>
	<tr>
		<td colspan="7" height="1" class="spaceRow"><img src="../templates/subSilver/images/spacer.gif" alt="" width="1" height="1" /></td>
	</tr>
	<!-- END catrow -->
	<tr>
		<td colspan="7" class="catBottom"><input class="post" type="text" name="categoryname" /> <input type="submit" class="liteoption"  name="addcategory" value="{L_CREATE_CATEGORY}" /></td>
	</tr>
</table></form>
i use subsilver and ambience themes.. well why phpbb doesnt have their own sub boards in their forum..i wish atleast the newer version have them:)
Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: installin simple subforum how to???? help

Post by Nightrider »

Your text link worked just fine. That is the best way to go...

This is a simple fix. Again you can work around these types of problems by simplifying the FIND statement down to a unique word or phrase...

So do this:

OPEN
simple_subforums_1.0.1.txt

FIND

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
		<td class="row2"><span class="gen"><a href="{catrow.forumrow.U_VIEWFORUM}"
REPLACE WITH

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
{catrow.forumrow.U_VIEWFORUM}
Save, upload, and try again using EM...

Image
Locked