internal server error

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
cellulosa
Registered User
Posts: 9
Joined: Thu May 25, 2006 1:15 pm

internal server error

Post by cellulosa »

i'm sorry i already sought this problem into the forum but the solutions that you said not worked for me.. i had installed the EasyMod and all works perfectly.. (the installer say me that there are no errors) but when i try to open the Easy Mod config by admin panel the server print this:

Code: Select all

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, ---------@----------.--- and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
i tried to reinstall it but the problem remain.

i have FTP access and in the installer all works (the installer said)


this is the debug info:
(formatted for forum posting)
EM installer v0.3.0 wrote: Update EM from: 0.3.0
phpBB version: 2.0.20
Working Dir: /web/htdocs/www.----------.net/home/forum/admin/mods/easymod
Install Step: 1
Mode: debug

The Error wrote: No error.

Permissions: (including system errors)
read access :: OK
write access :: OK
root path write :: OK
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: OK


Additional System Information:

System: Linux webx51.aruba.it 2.6.9-34.ELsmp #1 SMP Wed Mar 8 00:27:03 CST 2006 i686
Configure Command: './configure' '--prefix=/php_4.4.1' '--with-mysql=/usr' '--with-jpeg-dir=/usr/lib/' '--with-zlib' '--with-png-dir=/usr/lib' '--with-config-file-path=/etc/apache/' '--with-gd' '--disable-debug' '--enable-inline-optimization' '--enable-memory-limit' '--with-imap=/usr/local/imap-2004g/' '--with-imap-ssl' '--with-mcrypt' '--enable-ftp' '--enable-xslt' '--with-xslt-sablot' '--with-ttf' '--with-freetype-dir=/usr/include/freetype2/freetype/' '--with-t1lib=/usr/include/' '--with-gettext' '--enable-exif' '--enable-bcmath' '--enable-calendar' '--with-dom' '--enable-discard-path' '--disable-path' '--with-bz2' '--with-mhash' '--with-mime-magic' '--with-curl' '--enable-wddx' '--with-expat' '--disable-ipv6'
PHP version: 4.4.1
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: N/A


Recommendations:
write: server
move: copy

Selected settings:
write:
move:
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x .
drwxr-xr-x ..
drwxr-xr-x includes
drwxr-xr-x languages
drwxr-xr-x em_includes
-rwxr-xr-x easymod_install.php
-rwxr-xr-x easymod.gif
-rwxr-xr-x easymod_display_functions.php
drwxr-xr-x templates
-rw-r--r-- post_process.sh
-rw-r--r-- post_process.bat

Not testing FTP since it is not being used.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: internal server error

Post by Nightrider »

Usually from what I have seen, an Internal Server Error is caused by a Permissions problem, usually in one of your forum's parent folders. On most servers, folder permissions should be set to 755 and file permissions to 644. But there are exceptions, such as on Awardspace and Lycos sites to name a few where file permissions MUST BE set to 755...

Are you using an Awardspace or Lycos site? I notice your permissions below show that almost everything is set to 755, except for a couple of files that EM creates, which are set to 644. If you are using a site that requires that both your file and folder permissions be set to 755, then I have a special version of EM that you probably will have to install to workaround your permissions problem...

CHMOD Permissions

Do you have the permissions of the folders set to 755 and the files set to 644? On most boards, the folder permissions must be set to 755 and the file permissions to 644. However on some, such as Awardspace and Lycos, the folder and file permissions MUST BE set to 755. Check some of your other non-EM file and folder permissions to determine what works on your site...

You can probably find instructions on how to do that at the site that provides your FTP application. I'm sure it varies from application to application...

I use SmartFTP. All you need to do is click on a folder or file in the right hand viewer and choose Properties/CHMOD or Alt+Enter

Image

Then you can either enter the value, like 755 or 644, or you can click on the read, write, execute options, which do the same thing...

Image

Image

User avatar
givemegraphics.com
Registered User
Posts: 45
Joined: Wed Mar 01, 2006 12:02 am

Re: internal server error

Post by givemegraphics.com »

Excelent reply.... complete with visuals... way to go.... :lol:

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: internal server error

Post by Nightrider »

Spam isn't allowed here givemegraphics.com. You're lucky that no one is minding the store...

Image

cellulosa
Registered User
Posts: 9
Joined: Thu May 25, 2006 1:15 pm

Re: internal server error

Post by cellulosa »

thanks i know how to set permission but i've got my own web space under aruba.it with my own domain name.

i have controlled and folders and files CHMOD (exept upload and cache folder that are 777) are all 755..

cellulosa
Registered User
Posts: 9
Joined: Thu May 25, 2006 1:15 pm

Re: internal server error

Post by cellulosa »

ok! :mrgreen:
now the things works!
i changed the "/forum/admin/admin_easymod.php" file CHMOD to 755.. (first was 644)

thank you!

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: internal server error

Post by Nightrider »

If your file permissions have to be set to 755 to function, then your EM installation probably isn't going to work at all. Are you on a Lycos or Awardspace site? If so, I have a special version of EM for you to install that would work on your site...

Image

cellulosa
Registered User
Posts: 9
Joined: Thu May 25, 2006 1:15 pm

Re: internal server error

Post by cellulosa »

nono i'm not under Lycos or Awardspace site.
all of my permissions are default 755.. now all works.. like i wrote before i changed admin_easymod.php permission to 755 'cause it was 644

cellulosa
Registered User
Posts: 9
Joined: Thu May 25, 2006 1:15 pm

Re: internal server error

Post by cellulosa »

uhm.. no now i've got some problems again... i've tried to install the advancedversioncheck MOD but in the second step of the installation the board show me

Code: Select all

Forbidden

You don't have permission to access /forum/admin/admin_easymod.php on this server.
.. and now i can't see the administration panel with the same internal server error..


my folders and files permissions are normally set to 755.. try to attach me your version..
Last edited by cellulosa on Fri May 26, 2006 12:53 pm, edited 1 time in total.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: internal server error

Post by Nightrider »

Could you tell me who your host is so that if this problem comes up with someone else, I will know that they have a similar problem as we have with Awardspace and Lycos sites???

Download and install this Awardspace version of EM. It should work just as well on your site since both your file and folder permissions must be set to 755...

Before you can install EM again, you will have to decrease the EM version number. If you can get into EM Settings, decrease the EM version number to something like 0.1.13 or 0.2.1. Anything less than 0.3.0 will work. If you can't get into EM Settings, use the following to change the EM version number:

EM Version Change

If you already had EM 0.3.0 installed, then you will need to change the EM Version back so that the install will think that this is an Upgrade. You can use this tool to change your EM Version so that you can reinstall EM on your board:

EM_Version_Changer

Once the EM Version Changer is installed, set the EM version to 0.1.13 or 0.2.0...

EM Version Change (Manual Option)

If you want to manually change the EM version, you can do so in your phpbb_config table. Just look for the record beginning with EM_version. Then you can change the related field to 0.1.13. You could also delete all the records in the phpbb_config table that begin with EM_ and delete the phpbb_easymod table too to have the new install recreate everything...

Awardspace Instructions w/Download

You can download this EM version that I have modified to work on Awardspace sites. The file can be found in the downloads/phpBB/EasyMod section at the top of the page. Make sure that all uploaded file permissions are set to 755:

easymod_awardspace.zip

Here are the instructions for modifying your EM installation files if you choose to do it yourself rather than use the modified EM version that I supplied above:

Awardspace Modifications

Your board requires script file permissions to be set to 755 instead of 644 like most other boards. So even if EM installs correctly, the EM file permissions would be set to 644...

Unfortunately for sites like your's, EM sets the file permissions to 644 when it modifies them. So go into the following files to set all matches of 0644 to 0755 before you install EM:
  1. easymod/em_includes/em_modio.php
  2. easymod/em_includes/em_ftp.php
Also, modify the check_file_scope function in your easymod/includes/admin_easymod.php.txt file by copying and pasting the code:

OPEN
easymod/includes/admin_easymod.php.txt

FIND

Code: Select all

if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
REPLACE WITH

Code: Select all

//if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
	if( !@file_exists(phpbb_realpath($filename)) )
The check_file_scope function should now look like this:

Code: Select all

function check_file_scope($filename, $expected_scope, $simply_die = false)
{
	global $db, $lang;

	// make sure a file is located somewhere inside the specified directory
	//if( !@file_exists(phpbb_realpath($filename)) || !strstr(phpbb_realpath($filename), phpbb_realpath($expected_scope)) )
	if( !@file_exists(phpbb_realpath($filename)) )
	{
		$message = sprintf($lang['EM_modio_open_read'], $filename);
		if( $simply_die )
		{
			$db->sql_close();
			die($message);
		}
		message_die(GENERAL_ERROR, $message);
	}
}
Save all the modified files and upload them to their proper sub-folders in the admin/mods/easymod folder. Then go ahead and try the EM install again...

Image

Locked