Just looped back

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

I dont need a port to connect to the FTP server.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Sure you do. You may not realize it though. Or are you hosting your own site???

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

I am using DHost and the URL is dhost.info/farmallama
I cant see any port settings, except 80, but I have tried it and it still doesnt go. Could I have the permissions wrong, and BTW, what are the permissions?

Thanks,
Tim.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Most FTP servers use Port 21, so it would be unusual if your host uses Port 80. I'm sure it is possible. So in your FTP login details, you would change the default Port 21 to Port 80 and then include your login details to your FTP Server as well...

There are lots of different permissions. Your folders CHMOD permissions should be set to 755 and your files to 644. You can change those permissions in your FTP application. I prefer and recomment using SmartFTP because it is free and powerful...

You also have Database permissions that determine what the dbuser can and can't do to the database. Hopefully your dbuser has full privileges to your database or that may become a problem in the EM install down the road...

Your problem doesn't seem to be a permissions issue yet. We need to figure out what Port you should be using...

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

Final Step: EasyMOD is now confirming all files have been correctly moved into place. If confirmed, then your database will be updated and installation will be complete!




admin_easymod.php, looking for: admin_easymod.php
Confirmed!


mod_install.tpl: verifying existence
Confirmed!



Updating EasyMOD table data
Storing config table entries: Done

Executing SQL: INSERT INTO phpbb_easymod ( mod_title, mod_file, mod_version, mod_author_handle, mod_author_email, mod_author_name, mod_author_url, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited, mod_tables_added, mod_tables_altered, mod_rows_inserted) VALUES ( 'EasyMOD', 'easymod/easymod_install.php', '0.3.0', 'Nuttzy', 'pktoolkit@blizzhackers.com', 'n/a', 'http://www.blizzhackers.com', 'EasyMOD automatically perfoms in seconds which previously required the tedious task of manually editing files.', 1139966173, '2.0.19', 'subSilver; subBlack', 'english', 0, 1, 0, 1)

Progress :: . Done
Result :: No errors

Storing processed files table

Executing SQL:
INSERT INTO phpbb_easymod_processed_files (mod_processed_file, mod_id) VALUES ('admin/admin_easymod.php', 1)

Progress :: . Done
Result :: No errors



Installation Confirmed. EasyMOD is installed!

You can now proceed to the Admin Control Panel and select "Install MODs" under "MOD Center". You may install the included MODs if you desire. Return to Forum Index.

Ahhhh, thats better. I got different hosting, I was pretty stupid in the first place, I forgot what FTP was, and I was able to get FTP access before. Now I know, it installed it automatically and now I am looking forward to installing mods! Thanks so much.I kind of forgot about this thread.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Congratulations Timtam!!! Better late than never. I'm glad that you shared your success story with us...

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

EM installer v0.3.0 wrote: Update EM from: 0.3.0
phpBB version: 2.0.19
Working Dir: /var/www/html/forum/admin/mods/easymod
Install Step: 1
Mode:

The Error wrote: Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.

Permissions: (including system errors)
read access :: OK
write access :: OK
root path write :: OK
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: OK


Additional System Information:

System: Linux host159.host159-server.com 2.6.10-1.771_FC2 #1 Mon Mar 28 00:50:14 EST 2005 i686
Configure Command: './configure' '--host=i386-redhat-linux' '--build=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-db4=/usr' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-ncurses' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-regex=system' '--with-xml' '--with-expat-dir=/usr' '--with-dom=shared,/usr' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-xmlrpc=shared' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl' '--with-kerberos' '--with-ldap=shared' '--with-mysql=shared,/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-bcmath' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mcal' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-force-cgi-redirect'
PHP version: 4.3.10
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: enabled


Recommendations:
write: server
move: copy

Selected settings:
write:
move:
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

-rw-r--r-- easymod_install.php
drwxr-xr-x .
drwxr-xr-x includes
drwxr-xr-x languages
-rw-r--r-- easymod.gif
drwxr-xr-x em_includes
-rw-r--r-- easymod_display_functions.php
drwxr-xr-x templates
drwxr-xr-x ..

Not testing FTP since it is not being used.


This is what I get after I thought I had deleted the files, so I can re-install EM.
I dont think there is any other files anywhere. Is there something in another file that I can edit that enables me to install EasyMod again?

User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Just looped back

Post by Nux »

Generally rule - don't be scared of error messages. ;)
If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.
And "here" was (or should be):
viewtopic.php?f=24&t=13559&start=17#92295

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

But you see, heres the thing. I have deleted all the files, I have done the version changer, and it just says Template->make_filename(): Error - file admin/mod_login.tpl does not exist


What if I upload this file? Or is there some file I can edit that enables me to re-install it, like where it has saved the info on what version I have, that I can edit?

Locked