Just looped back

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Just looped back

Post by Timtam »

Hello,
I am new to Easy Mods.
I have recently downloaded it, and when I go to install it, when I go to the installation file, I am asked to log in, and then I am sent back to dhost.info (I am with them).
I have done everything so far all correct,but now, this is happening.
Please help.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Clear the cookies to your board in your browser. If that doesn't fix the problem, make sure that the cookie path is set to / in your General Admin Configuration page. If you have to change that setting, all of your members will have to clear the cookies to your board in their browser in order to login to your board...

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

I have done that, I get to the screen after that (The one asking you if you have FTP access) I say yes, (I have tried them all) and it asks me to log in, then I do, then it loops back to this screen again. I have tried cliking on Debug and still the same thing happens.
The cookie is set to / .

This is getting annoying.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

If your cookies are set correctly, you should never see the login page for the EM install. That is usually a sign that something is wrong with your cookies. I have been able to install EM for people without logging into their board...

Nux had a fix that seemed to work for some people. Try what he mentions in this topic:

Install error

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

Nope, it still wont work.
I dont know what it is now, this is really really really annoying.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Maybe one of the others can offer a different suggestion. I need to call it a night though. If this isn't resolved tomorrow, maybe I can help look into it a bit deeper. Usually everything that I have already suggested works for this problem so you might want to go through everything I said at least one more time to make sure you didn't miss anything...

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

I have started my forum again, hopefully now I will get somewhere. I found out that I dont have FTP access,so that is probabaly why I cant get it going.
I will try again anyway, and see what happens, and I will say how I went, if I was sucessful or not.

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

I will be interested in hearing whether you made any progress with this. Good Luck Timtam!!!

Image

User avatar
Timtam
Registered User
Posts: 19
Joined: Fri Jan 13, 2006 10:30 am
Location: Australia

Re: Just looped back

Post by Timtam »

I have got as far as the screen which asks you to set an Easy Mod password (for the mods and Admins) and I click submit and I get:

Testing selected write method
Testing FTP access...

FTP ERROR: connection to mysql:21 failed.
This error occurs frequently when the port number is incorrect. Back on step 1 you should try changing the FTP Port from 21 to whatever port you typically use when you FTP.


Here is the Debug Info:

EM installer v0.3.0 wrote: EM status: New Install
phpBB version: 2.0.19
Working Dir: /usr/local/apache2/htdocs/farmallama/admin/mods/easymod
Install Step: 2
Mode: debug

The Error wrote: No error.

Permissions: (including system errors)
read access :: OK
write access :: No
root path write :: No
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: No
FTP extension :: module not loaded
Safe Mode :: ON
copy access :: No


Additional System Information:

System: Linux dhost.info 2.6.10-1.771_FC2 #1 Mon Mar 28 00:50:14 EST 2005 i686
Configure Command: './configure' '--with-mysql' '--with-apxs2=/usr/local/apache2/bin/apxs'
PHP version: 4.4.0
register_globals: OFF
magic_quotes_gpc: OFF
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: N/A


Recommendations:
write: buffer & ftp
move: automated FTP

Selected settings:
write: ftpb
move: ftpa
ftp dir: dhost.info/farmallama
ftp host: mysql
ftp port: 21
ftp debug: true
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x .
drwxr-xr-x ..
drwxr-xr-x em_includes
drwxr-xr-x includes
drwxr-xr-x languages
drwxr-xr-x templates
-rw-r--r-- easymod.gif
-rw-r--r-- easymod_display_functions.php
-rw-r--r-- easymod_install.php
Testing FTP access...
Trying to connect to mysql:21 ...
Error : Cannot connect to remote host "mysql:21"
Error : fsockopen() Connection refused (111)

FTP ERROR: connection to mysql:21 failed.
This error occurs frequently when the port number is incorrect. Back on step 1 you should try changing the FTP Port from 21 to whatever port you typically use when you FTP.

Now I am really stuck. Can someone please help?

Nightrider
Registered User
Posts: 7219
Joined: Tue Nov 16, 2004 8:54 pm
Location: Florida, US
Contact:

Re: Just looped back

Post by Nightrider »

Can you access your FTP server using an FTP application using Port 21 or do you have to use some other port to access it???

Image

Locked