EasyMOD tab doesn't appear in Admin CP

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
Saint Shinryu
Registered User
Posts: 4
Joined: Sat Jul 23, 2005 3:49 am

EasyMOD tab doesn't appear in Admin CP

Post by Saint Shinryu »

Well, I just recently fixed the problem I had here: http://www.phpbb.com/phpBB/viewtopic.php?t=309520" target="_blank

Where I accidentally deleted my config.php in an attempt to uninstall a mod. :oops:

Anyway, the problem is, after fixing this, I go to my admin CP, and find that the EasyMOD tab is gone. I had it before the "incident" described in that link. So I figured it wasn't installed anymore. I went to install it again, and got the following error:
Step 1 (gathering settings): Welcome to the EasyMOD installer. EasyMOD will try to guide you every step of the way. First, we need to know a little about your server.



Error

Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.


Expanded Debug Info
(formatted for forum posting)
EM installer v0.2.1a wrote: phpBB version: 2.0.16
Working Dir: /home/.cappy/ryu/shoujo-anime.net/admin/mods/easymod
Install Step: 1
Mode:
The Error wrote: Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.
Permissions: (including system errors)
read access :: OK
write access :: OK
root path write :: OK
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: OK



Recommendations:
write: server
move: copy

Selected settings:
write:
move:
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x .
drwxr-xr-x ..
-;rw-r--r-- easymod.gif
-;rw-r--r-- easymod_display_functions.php
-;rw-r--r-- easymod_install.php
-;rw-r--r-- easymod_install.php~
drwxr-xr-x em_includes
drwxr-xr-x includes
drwxr-xr-x languages
drwxr-xr-x templates

Not testing FTP since it is not being used.
I have absolutely no idea what to do.

EDIT: Also all of my prior mods seem to be missing also and I'm assuming have the same problem
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: EasyMOD tab doesn't appear in Admin CP

Post by ChALkeR »

Code: Select all

UPDATE `phpbb_config` SET `config_value` = '0.0.0' WHERE `config_name` = 'EM_version' LIMIT 1 ;
then reinstall.

actually you have the file ./admin/admin_easymod.php missing. instead of reinstalling you can try to copy it from the pack, but there is no guarantee that you have all the other files where they are supposed to be.
Image
Sorry for my bad English....
Saint Shinryu
Registered User
Posts: 4
Joined: Sat Jul 23, 2005 3:49 am

Re: EasyMOD tab doesn't appear in Admin CP

Post by Saint Shinryu »

Actually, I already fixed it and was just on my way to say so. Thanks, though.
Locked