Quick question with admin/mod_header.tpl

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
[SFV]zerk
Registered User
Posts: 3
Joined: Tue Jul 19, 2005 3:16 pm

Quick question with admin/mod_header.tpl

Post by [SFV]zerk »

Okay, I have this mod running FINE on one website but it is giving me more trouble that it is worth on another. After LOTS of fidgeting around I finally get the installer to say complete. Thinking I was done I go into the admin and it says:

Template->make_filename(): Error - file admin/mod_header.tpl does not exist
I use helius style normally but I switched to subsilver to try to install. The file folder name of the easymod version I am using is .13 I believe, though I had to change the version number to try to install it to 12.

Any help would be appreciated. I did a quick search and found nothing related.

Regards,
zerk
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Quick question with admin/mod_header.tpl

Post by Nux »

Get the latest version - we're 2.0.1a now :). Maybe there was some issue about that, though I don't recall that. Remeber to delete all files in admin/mods/easymod.
[SFV]zerk
Registered User
Posts: 3
Joined: Tue Jul 19, 2005 3:16 pm

Re: Quick question with admin/mod_header.tpl

Post by [SFV]zerk »

Okay, did that... Now im left with
Template->make_filename(): Error - file admin/mod_login.tpl does not exist
I completey deleted the folder and reuploaded the new one :S I had to FTP the stuff manually, though there were no files to actually upload. What did I screw up?
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Quick question with admin/mod_header.tpl

Post by Nux »

Hm... I guess you didn't upload all files. Unfortunatly EM dosen't really check that all files are uploaded correctly so it will say that everythin is OK even if it isn't :?... So you have to make sure that all files are actually copied. Of course when you use automatic moving method then mostly (if not always) all files will get copied or you will get some errors or warnings. My best advice would probably be to use the automatic method...

One thing troubles me, I think (not sure) that in previous versions (0.1.x) of EM some of the oryginall files were changed, but this doesn;t happen in new versions. So maybe your problems is here... I don't have the time to check that now so maybe wGeric or GPHemsley will help you :roll:.


Vacation, here I come. :D
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: Quick question with admin/mod_header.tpl

Post by ChALkeR »

Nux wrote: we're 2.0.1a now :)
actually 0.2.1a
Image
Sorry for my bad English....
prodaea
Registered User
Posts: 2
Joined: Thu Jul 21, 2005 8:59 pm

Re: Quick question with admin/mod_header.tpl

Post by prodaea »

i also get the same message when i click on any of the easy mod admin links
prodaea
Registered User
Posts: 2
Joined: Thu Jul 21, 2005 8:59 pm

Re: Quick question with admin/mod_header.tpl

Post by prodaea »

ok, i checked some older posts. the solution is to copy the contents of the includes folder (*.tpl, et. al.) into all of your other style/admin folders. the install program only installs these files into subsilver i believe.
User avatar
Nux
Registered User
Posts: 943
Joined: Tue Jun 14, 2005 5:09 pm
Location: 3cities, Poland
Contact:

Re: Quick question with admin/mod_header.tpl

Post by Nux »

ChALkeR wrote:
Nux wrote: we're 2.0.1a now :)
actually 0.2.1a
Typed that too many times I guess ;).
prodaea wrote: ok, i checked some older posts. the solution is to copy the contents of the includes folder (*.tpl, et. al.) into all of your other style/admin folders. the install program only installs these files into subsilver i believe.
That is what you suppose to do in the instalation (if not done automaticly).

Greets :).
Locked