help!!!!

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Locked
ExtremeGL
Registered User
Posts: 2
Joined: Wed Jul 06, 2005 1:17 pm
Location: Springfield
Contact:

help!!!!

Post by ExtremeGL »

I made an attempt to install easyMOD last week, then it didnt work, so I deleted the files. A friend's installing it for me again, and he says it says "Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation."...What do I need to do to uninstall the previous attempted installation?

Need URGENT help!
Thanks in advance!!
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: help!!!!

Post by ChALkeR »

SQL

Code: Select all

DROP TABLE `phpbb_easymod`
Image
Sorry for my bad English....
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: help!!!!

Post by GPHemsley »

No... just use the Version Changer to change the version to something other than what you have installed (which should be 0.2.0), such as 0.2.0a. Then try to reinstall.
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: help!!!!

Post by ChALkeR »

what for? he has no mods installed with easymod. and sql is easyer =)))
Image
Sorry for my bad English....
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: help!!!!

Post by GPHemsley »

Dropping the EasyMOD table won't even fix the problem, so no, SQL is not easier.
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: help!!!!

Post by ChALkeR »

it will.
Image
Sorry for my bad English....
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: help!!!!

Post by GPHemsley »

ChALkeR wrote: it will.
I've been doing this longer than you have. Trust me, your SQL query will not fix the problem.
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: help!!!!

Post by ChALkeR »

ok. i see, em also writes its verion data to phpbb_config.
But i see no point on doing that, because it already exists in phpbb_easymod.
Image
Sorry for my bad English....
User avatar
GPHemsley
Registered User
Posts: 1617
Joined: Fri Apr 18, 2003 4:01 am
Location: Long Beach, NY
Contact:

Re: help!!!!

Post by GPHemsley »

ChALkeR wrote: But i see no point on doing that, because it already exists in phpbb_easymod.
They are used for two different purposes. The one in config is the version tracker. The one in easymod is the entry for EasyMOD, which it treats as any other MOD you may have installed.
ChALkeR
Registered User
Posts: 176
Joined: Tue Mar 15, 2005 4:38 pm
Location: Russia

Re: help!!!!

Post by ChALkeR »

GPHemsley wrote:
ChALkeR wrote: But i see no point on doing that, because it already exists in phpbb_easymod.
They are used for two different purposes. The one in config is the version tracker. The one in easymod is the entry for EasyMOD, which it treats as any other MOD you may have installed.
i know that. but this:

Code: Select all

SELECT `mod_version` FROM `phpbb_easymod` WHERE `mod_title`='EasyMOD' ORDER BY `mod_id` DESC LIMIT 1;
will bring you your EM version

what for does it have another field in config?
Image
Sorry for my bad English....
Locked