[unsolveable - ftp] Another 0.1.13 FTP problem!

Having problems installing EM? Let's fix that
Forum rules
DO NOT give out any FTP passwords to anyone! There is no reason to do so! If you need help badly enough, create a temporary FTP account that is restricted to only the files that you need help with and give the information for that. Giving out FTP information can be very dangerous!
Registered User
Posts: 1
Joined: Thu Aug 19, 2004 12:11 am

[unsolveable - ftp] Another 0.1.13 FTP problem!

Post by strzelecki »

Ok, been struggling for ages on this, need help. All the permisions are ok, even tried chmod 777 at one point. It appears that ftp login is failing all the time becuase install always reverts to passive mode.

File Access Info
Let's see what you have for file access. You do not need everything to read 'ok'.

read access :: OK
write access :: OK
root path write :: No
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: OK
FTP extension :: module not loaded
Safe Mode :: OFF
copy access :: OK

Testing FTP access...
Trying to connect to ftp.sukuf.co.uk:21 ...
220 ProFTPD 1.2.7 Server (Web Mania) [server5.web-mania.com]
Connected to remote host "ftp.sukuf.co.uk:21"
> USER RukuftioS
331 Password required for RukuftioS.
> PASS ********
230 User RukuftioS logged in.
Authentication succeeded
1) Logged in successfully
257 "/" is current directory.
PWD: /
227 Entering Passive Mode (193,22,244,20,168,73).
Trying to ...
Error : Cannot open data connection to
Error : Connection timed out (110)
Error : Cannot connect to remote host
Error : NLST command failed
Dir listing: (1 files being listed)
> CWD /home/www/RukuftioS/forum/admin/mods/easymod
421 No Transfer Timeout (300 seconds): closing control connection.
Error : CWD command failed

FTP ERROR: could not cd to /home/www/RukuftioS/forum
You successfully logged into the server, but could not change direcory (CD) to the easymod directory. The following is recommended:

I've tried putting the ftp server as localhost, sukuf.co.uk, ftp.sukuf.co.uk and the ip address. I've also tried changing the phpBB root from /forum to forum/ to /home/www/RukuftioS/forum and tried every combination of these 2 parameters possible! Why can't it just carry on in none passive ftp mode? It's seems to connect and login ok. The easymod directory is correct and chmodded ok. Stuck now, unless I can get my host to enable php ftp. Any ideas?
Registered User
Posts: 927
Joined: Fri Aug 03, 2001 7:09 am

Re: Another 0.1.13 FTP problem!

Post by Nuttzy99 »

Well, you fall into the tiny minority of people that have a passive mode problem AND do not have the FTP extension loaded. Fortunately since you don't have Safe Mode on and you can chmod 777 then you don't need to use FTP! Just use server for the write method and copy for the move method!

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
My Other Site