[RFC] Disable the extensions while updating the board

Note: We are moving the topics of this forum and it will be deleted at some point

Publish your own request for comments/change or patches for the next version of phpBB. Discuss the contributions and proposals of others. Upcoming releases are 3.2/Rhea and 3.3.
Post Reply
Nicofuma
3.2 Release Manager
3.2 Release Manager
Posts: 297
Joined: Sun Apr 13, 2014 1:40 am
Location: Paris

[RFC] Disable the extensions while updating the board

Post by Nicofuma » Mon Jul 14, 2014 6:13 pm

Context
The updates can introduce backward compatibility breaks for the extensions.

Per example 3.1.0-RC2 introduces a new abstraction layer for the database layer represented by a new interface \phpbb\db\driver\driver_interface which has to be used instead of the abstract driver class \phpbb\db\driver\driver. With this update all the extensions which need the database driver to work were broken. And any board having one of these extension enabled was inaccessible (a PHP error was displayed).

Proposal
Disable the extensions during the update.

But there is a few questions about this:
  1. Does we want to disabled the extensions during the update?
  2. If yes, should it be done only for the automatic updater?
  3. Should these extensions have a special status saying they were disabled by the updater?
Pro
  • The board can not be broken during the update process, so the admin can not think that his board was broken by the core.
  • To complete...
Cons
  • In 3.0.x the MODs are not disabled during the update.
  • The admin can still broke his board by re-enabling the broken extension (he can't really know that the extension is broken).
  • When disabling the extension we can lose some config settings (ie: the default captcha) which will not be restored when the extension will be enabled again.
  • To complete...
Member of the phpBB Development-Team
No Support via PM

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [RFC] Disable the extensions while updating the board

Post by nickvergessen » Mon Jul 14, 2014 7:12 pm

I think we should stay with the old 3.0 way here.
Let it break, if it does break. Having to re-enable all extensions after an update is more annoying then useful here.
All admins will try to reenable the extensions anyway. So instead of having them to enable them and then get the error,
let them just see the error right away.
Member of the Development-TeamNo Support via PM

User avatar
VSE
Extension Customisations
Extension Customisations
Posts: 670
Joined: Mon Mar 08, 2010 9:18 am

Re: [RFC] Disable the extensions while updating the board

Post by VSE » Tue Jul 15, 2014 3:45 am

nickvergessen wrote:I think we should stay with the old 3.0 way here.
Let it break, if it does break. Having to re-enable all extensions after an update is more annoying then useful here.
All admins will try to reenable the extensions anyway. So instead of having them to enable them and then get the error,
let them just see the error right away.
+1

I can only imagine the pain of having to re-enable dozens of extensions after an update :cry:

I think a better solution may be to promote the STK for 3.1, which should have a Disable all Extensions feature, which could then be used in those cases where a board breaks on update due to extensions.

Once 3.1 is officially released, these breaks should probably be more rare than right now, because we are still changing things quite a bit now.
Has an irascible disposition.

User avatar
Sumanai
Registered User
Posts: 95
Joined: Sat Aug 31, 2013 11:12 am

Re: [RFC] Disable the extensions while updating the board

Post by Sumanai » Tue Jul 15, 2014 3:07 pm

Maybe just check before updating extensions for compatibility with the latest version board? And displays a warning about the potential incompatibility with the list of extensions and offer to update them before updating board?
Sorry for my English.

User avatar
nickvergessen
Former Team Member
Posts: 733
Joined: Sun Oct 07, 2007 11:54 am
Location: Stuttgart, Germany
Contact:

Re: [RFC] Disable the extensions while updating the board

Post by nickvergessen » Tue Jul 15, 2014 7:34 pm

Sumanai wrote:Maybe just check before updating extensions for compatibility with the latest version board? And displays a warning about the potential incompatibility with the list of extensions and offer to update them before updating board?
Not really sure if that should be in phpbb, but I guess some kind of compatibility script would be nice to have
Member of the Development-TeamNo Support via PM

Post Reply