Search found 894 matches

by MichaelC
Sat Feb 06, 2016 4:46 pm
Forum: [3.x][Archive] RFCs
Topic: Doctrine DBAL
Replies: 8
Views: 9895

Re: Doctrine DBAL

Nicofuma wrote:
Fri Jan 29, 2016 10:52 pm
+1 on the initial proposal: nuke our current DBAL, expose doctrine dbal through a new service and make the service dbal.conn a simple wrapper for the doctrine service (wrapper which will be nuked in 4.0)
+1 to this

https://tracker.phpbb.com/browse/PHPBB3-14463
by MichaelC
Mon Aug 24, 2015 11:22 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 73524

Re: PHP requirement

<MichaelC> Tbh, with drupal bumping it's minimum requirement to 5.5, I don't think it's something we should be worrying about (hosts not having updated) <MichaelC> Also, if we are only going to 5.5 in one year, then by the time we jump to php7 or 5.6, 7.4 will have been released. <MichaelC> Drupal m...
by MichaelC
Mon Aug 24, 2015 7:00 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 73524

Re: PHP requirement

My suggestion for a trade off would probably be something like this: Support the PHP version not EOL on release of final, unless a dependency requires a larger version. Seems good enough for me. @Nicofuma, what do you think? That would be 5.5 for phpBB 3.2. I think we should leave establishing a se...
by MichaelC
Mon Aug 24, 2015 3:34 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 73524

Re: PHP requirement

They don't care about people, they do care about projects saying to upgrade (GoPHP5) Nah. They only care about what WordPress minimum requirement is, since that what 95% of their users want to use, which is 5.2. According to this, 5.3 is still dominant :/ http://w3techs.com/technologies/details/pl-...
by MichaelC
Mon Aug 24, 2015 1:16 pm
Forum: [3.x] Discussion
Topic: PHP requirement
Replies: 46
Views: 73524

Re: PHP requirement

+1 to 5.4 or, preferably 5.5 (As it won't be EOL). Drupal 8 (release in a few months) requires PHP 5.5 (not 5.6 Tristan) so hosts will be forced to update in the next few months anyway although most major shared hosts are now running 5.5, one exception being BlueHost who Drupal are working with to u...
by MichaelC
Sat Jun 13, 2015 11:07 am
Forum: General Development Discussion
Topic: Tracker
Replies: 4
Views: 4637

Re: Tracker

As far as I know the website team is aware of the issue, I don't know when they will fix it. Until then the only solution is to contact a manager to reset your login attempts manually. Correct. Unfortunately this is a limitation of our JIRA/Crowd/phpBB Logins authentication system and is not someth...
by MichaelC
Sat Mar 28, 2015 6:17 pm
Forum: General Development Discussion
Topic: Area51 MediaWiki Integration
Replies: 7
Views: 11922

Re: Area51 MediaWiki Integration

I know there isn't any phpBB specific code on the Area51 forums for the Mediawiki, but the MediaWiki itself probably looks at phpBB sessions and decides how to handle logins on MediaWiki. I'm mostly interested in the custom code / extension on the MediaWiki that was used. But it's no integrated her...
by MichaelC
Tue Feb 24, 2015 8:57 pm
Forum: [3.x][Archive] RFCs
Topic: [RFC] Automated Updating
Replies: 31
Views: 25464

Re: [RFC] Automated Updating

It would be nice to see this moving again if someone is willing to pick up the actual development of it.
by MichaelC
Tue Feb 24, 2015 8:55 pm
Forum: [3.x][Archive] RFCs
Topic: [RFC] composer phpBB versions and installation
Replies: 16
Views: 9233

Re: [RFC] composer phpBB versions and installation

https://area51.phpbb.com/phpBB/viewtopic.php?f=108&t=43427 Not sure how that fits in to this discussion? Does that somehow make requirements actually mean something and prevent installation of extensions into systems that don't meet those requirements? Correct. Dependencies on anything (other libra...
by MichaelC
Tue Feb 24, 2015 6:07 pm
Forum: [3.x][Archive] RFCs
Topic: [RFC] composer phpBB versions and installation
Replies: 16
Views: 9233

Re: [RFC] composer phpBB versions and installation

RMcGirr83 wrote:
nickvergessen wrote:That's the plan, we just didn't manage to finish that in time for 3.1
Ticket or no Joas? I'll open one if one doesn't exist.
https://area51.phpbb.com/phpBB/viewtopi ... 08&t=43427