phpBB API Documentation
Namespace

phpbb\db\driver

driver Database Abstraction Layer
factory Database Abstraction Layer
mssql MSSQL Database Abstraction Layer Minimum Requirement is MSSQL 2000+
mssql_base MSSQL Database Base Abstraction Layer
mssql_odbc Unified ODBC functions Unified ODBC functions support any database having ODBC driver, for example Adabas D, IBM DB2, iODBC, Solid, Sybase SQL Anywhere...
mssqlnative
mysql MySQL4 Database Abstraction Layer Compatible with: MySQL 3.23+ MySQL 4.0+ MySQL 4.1+ MySQL 5.0+
mysql_base Abstract MySQL Database Base Abstraction Layer
mysqli MySQLi Database Abstraction Layer mysqli-extension has to be compiled with: MySQL 4.1+ or MySQL 5.0+
oracle Oracle Database Abstraction Layer
postgres PostgreSQL Database Abstraction Layer Minimum Requirement is Version 8.3+
sqlite Sqlite Database Abstraction Layer Minimum Requirement: 2.8.2+
sqlite3 SQLite3 Database Abstraction Layer Minimum Requirement: 3.6.15+

Interfaces

driver_interface